[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[virgo-dev] Fwd: [Bug 378144] New: Hudson slave 2 fails jobs that succeed on slave 1

I have changed (hopefully all) the Virgo CI jobs to use Hudson slave 1 rather than (slave1 or slave 2) until this bug is fixed.

Regards,
Glyn

Begin forwarded message:

Subject: [Bug 378144] New: Hudson slave 2 fails jobs that succeed on slave 1
Date: 1 May 2012 10:29:09 GMT+01:00

https://bugs.eclipse.org/bugs/show_bug.cgi?id=378144
Product/Component: Community / Hudson

            Bug #: 378144
          Summary: Hudson slave 2 fails jobs that succeed on slave 1
   Classification: Eclipse Foundation
          Product: Community
          Version: unspecified
         Platform: PC
       OS/Version: Mac OS X
           Status: NEW
         Severity: normal
         Priority: P3
        Component: Hudson
       AssignedTo: webmaster@xxxxxxxxxxx
       ReportedBy: gnormington@xxxxxxxxxx


Raising this to capture an email thread with the web master and to get
something on the books before reconfiguring the failing Virgo builds to use
slave 1.

For example, the following builds shows failure on slave2 and success on slave
1, respectively:

https://hudson.eclipse.org/hudson/view/Virgo/job/virgo.osgi-test-stubs.snapshot/581/

https://hudson.eclipse.org/hudson/view/Virgo/job/virgo.osgi-test-stubs.snapshot/582/

The only possibly significant differences between slave 2 and slave 1
identified so far are:

1. slave 2 has workspace at /opt/buildhomes/hudsonBuild/workspace whereas slave
1 has it at /opt/users/hudsonbuild/workspace

2. slave 2 produces warnings in the console, e.g.:

<      [exec] [ivy:cachepath]     Pemfile
/opt/buildhomes/hudsonBuild/.ssh/id_rsa doesn't exist.

I have also tried deleting the workspace, but this does not help.

--
Configure bugmail: https://bugs.eclipse.org/bugs/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You reported the bug.