[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [pdt-dev] Can't get PDT to Debug PHP scripts on Win32 using xdebug

I thank you for the help. After downloading the 1.0.2 release version and adding the xdebug.remote_log lines to my php.ini, I discovered that my php.ini files was not properly formatted! I have corrected the problems in this file and now can debug PHP in PDT.


I do have another question: What’s the difference between the 1.0.2 Release Build and the 1.0.2 Stable Build? The name “Stable Build” would imply that it is more stable (that is less likely to crash or corrupt) than a “Release Build”; or am I reading something into these names that is not really there?



James R. Swenson

Information Technology Services

The Pennsylvania State University

jrs40@xxxxxxx, 814.863.1348


From: pdt-dev-bounces@xxxxxxxxxxx [mailto:pdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Dave Kelsey
Sent: Thursday, January 31, 2008 2:53 PM
To: PDT Developers
Subject: Re: [pdt-dev] Can't get PDT to Debug PHP scripts on Win32 using xdebug


Hi, first I suggest you move to the latest 1.0.2 release version (R20080103).

If you still have problems, then it may be worth trying with a new workspace (I don't know if older PHP projects and workspace settings are fully compatible with 1.0.2).

Ensure that xdebug is definitely loaded on the version of php you are using. To do this, use the launch configuration you are using to try to run your script in debug mode and change it to run a script with phpinfo.php in it.

Also a Debug log would be good, add something like
to your php.ini to generate a log.


Dave Kelsey


Unless stated otherwise above:
IBM United Kingdom Limited - Registered in England and Wales with number 741598.
Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU