[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Make org.eclipse.equinox.p2.publisher depend on org.eclipse.osgi

Hi p2 community,

 

In order to fix bug 427123, I’m proposing to require the bundle org.eclipse.osgi, i.e. Eclipse’s OSGi framework bundle, from org.eclipse.equinox.p2.publisher. This would mean that org.eclipse.equinox.p2.publisher wouldn’t run with other OSGi frameworks any more.

 

Is this an issue for anyone?

 

For details on the proposed change, see https://git.eclipse.org/r/#/c/32850/

 

Regards

Tobias