[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [eclipse-dev] [cross-project-issues-dev] Eclipse Project Photon (4.8) Plan Updated

Hi Ed

I'm not sure what you mean by "support". If you mean EMF can continue to code using 1.5, then that is not an issue. However, most plug-ins based on the Platform use the low-level bundles from the Platform like SWT or Resources. Those require 1.8 already for Oxygen.

> Conversely could you please enumerate the hopefully very few plugins that will have a greater than Java 8 BREE?
Currently no bundle uses Java 9 BREE. You can see the current BREE usage in our latest I-build in the following report: http://download.eclipse.org/eclipse/downloads/drops4/I20180110-2000/buildlogs/reporeports/reports/breedata.txt.

Dani



From:        Ed Willink <ed@xxxxxxxxxxxxx>
To:        eclipse-dev@xxxxxxxxxxx
Date:        11.01.2018 14:10
Subject:        Re: [eclipse-dev] [cross-project-issues-dev] Eclipse Project Photon (4.8) Plan Updated
Sent by:        eclipse-dev-bounces@xxxxxxxxxxx




Hi Dani
I can appreciate that maintaining the full list of minimal BREEs is a pain and not relevant for many of the entries, however without such a list for some plugins it is unclear to what extent the many modeling projects (EMF, UML2, OCL, ...) that continue to claim Java 5 support are able to do so.
org.eclipse.emf.core uses org.eclipse.core.resources and so it seems to me that unless the platform undertakes to provide Java 5 classes for org.eclipse.core.resources and its dependencies, then all projects that depend on org.eclipse.emf.core can only claim to be Java 8 and so should be built as Java 8. Could you please clarify the binary compatibility of the built classes.
Thr "Portions are targeted to specific classes of operating environments, requiring their source code to only reference facilities available in particular class libraries (e.g. Java 5, Java 6, etc)." observation is not helpful. If there is a Java 5 or Java 6 subsystem please identify it. If not please clearly state that the whole platform has an at least Java 8 minimum, although migration from legacy levels to Java 8 may not necessarily happen for Photon.
Conversely could you please enumerate the hopefully very few plugins that will have a greater than Java 8 BREE?
    Regards
        Ed Willink




On 11/01/2018 10:50, Daniel Megert wrote:
An updated version of the Eclipse top-level project plan for the Photon (4.8) release is now available:

http://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/eclipse/development/plans/eclipse_project_plan_4_8.xml

Notable changes are:
- The sub-project plans have been updated.
- Java 9 has been added to the target environments.
- The JRE versions have been updated.
- The appendix with the minimal BREEs has been removed.

Dani



_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev

Virus-free. www.avast.com


_______________________________________________
eclipse-dev mailing list
eclipse-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_eclipse-2Ddev&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=1UITCR5rxUZHSFczvfaNFK4ymEbEiccRX7VKchpqz0Y&m=MgB05DHK6PRVxRz7QAbBPgSejvKDPwcsG_BBKgt6grs&s=y5rAZ-1wb0UYdO3mujcNne2rTifE6BhwQEBwNQGPSa4&e=