[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[eclipse-dev] Should be announce the change of Bug 483340 as potentially breaking change on CROSS?

Hi,

in Bug 483340 we made ListenerList<E> implements Iterable.

AFAIK this is a potentially breaking change for plug-ins in the
release train if they have not updated their BREE to Java 1.5 as
java.lang.Iterable cannot be resolved in a pre-1.5 project.

If the above understanding is correct, I suggest to add this
requirement to the migration guide, the current entry does not mention
this requirement.

Best regards, Lars
-- 
Eclipse Platform UI and e4 project co-lead
CEO vogella GmbH

Haindaalwisch 17a, 22395 Hamburg
Amtsgericht Hamburg: HRB 127058
GeschÃftsfÃhrer: Lars Vogel, Jennifer Nerlich de Vogel
USt-IdNr.: DE284122352
Fax (040) 5247 6322, Email: lars.vogel@xxxxxxxxxxx, Web: http://www.vogella.com