[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [eclipse-dev] TimeoutException in Step Debugging

Hi Andrey,

Thank you for your reply.  I did not realize that bug 94452 had recent updates.  The 2005 and 2015 looked the same after so many hours of staring at the screen ;)

I can provide context if I'll have some more direction as to what context to provide.  In general, I am trying debug an open source application server -- https://github.com/lucee/Lucee -- via a debug project -- https://github.com/lucee/debug -- that has an embedded Jetty.

Please note the following:

1) There is a background thread running in the project to do maintenance at an interval of 5 seconds.  My breakpoints are on the main thread so I don't know if that might cause an issue.  The message box (nor the console) doesn't show any stack trace.  Can I get it elsewhere?

2) My colleague is running the same project in Eclipse Kepler (and many versions before) on a Mac with no issue.  So it looks to me like the problem is Windows-specific.

3) The project is debugged properly on IntelliJ IDEA on Windows

I will update to Eclipse 4.6M4 and test.

Thank you,

Igal Sapir
Lucee Core Developer
Lucee.org

On 1/29/2016 6:00 AM, Andrey Loskutov wrote:
Hi Igal,
It depends - you haven't provided much context to your problem, and the exception is way to generic to conclude the root cause from it.
 
It can be that you hit bug 94452 [1], where there is actually no timeout but debugger was interrupted.
Try 4.6 nightly build (or 4.6 M4) where this particular cause was eliminated.
 
But it can also be something with the application/environment itself, and you see real timeouts.
If this is still there please open a bug with steps to reproduce.
 
 
Kind regards,
Andrey Loskutov

http://google.com/+AndreyLoskutov
 
 
Gesendet: Freitag, 29. Januar 2016 um 06:42 Uhr
Von: "Igal @ Lucee.org" <igal@xxxxxxxxx>
An: eclipse-dev@xxxxxxxxxxx
Betreff: [eclipse-dev] TimeoutException in Step Debugging
Hi,

I consistently get an error while step debugging.  A modal message box pops up and says:

    org.eclipse.jdi.TimeoutException: Timeout occurred while waiting for packet NNNN.
    occurred creating step request.

Where NNNN is an integer that changes each time the error occurs.

A google search brings similar reports from 2005 (that's not a typo).

How can I resolve this?

Running Eclipse IDE for Java Developers version Kepler SR1 Build id: 20130919-0819
on Windows 7 Ultimate 64bit



Thank you,
 
--

Igal Sapir
Lucee Core Developer
Lucee.org

_______________________________________________ eclipse-dev mailing list eclipse-dev@xxxxxxxxxxx To change your delivery options, retrieve your password, or unsubscribe from this list, visit https://dev.eclipse.org/mailman/listinfo/eclipse-dev


_______________________________________________
eclipse-dev mailing list
eclipse-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev

PNG image