[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[eclipse-dev] I Do not succeed in running Eclipse on Linux Red Hat 7.1

Hi All,
I have downloaded eclipse-SDK-20011206-linux-motif.zip and extracted it in
/usr/eclipse.
I assumed that java -jar /usr/eclipse/startup.jar would start Eclipse.  But
that is not the case because there is no Manifest file in the startup.jar.
Next I copied /usr/eclipse/startup.jar into /usr/java/jdk1.3.1/jre/lib/ext
and ran java org.eclipse.core.launcher.Main.
I got the below messages:
Exception launching the Eclipse Platform:
java.lang.NullPointerException
	at org.eclipse.core.launcher.Main.searchForBoot(Main.java:309)
	at org.eclipse.core.launcher.Main.getBootPath(Main.java:260)
	at org.eclipse.core.launcher.Main.getBootLoader(Main.java:188)
	at org.eclipse.core.launcher.Main.basicRun(Main.java:148)
	at org.eclipse.core.launcher.Main.run(Main.java:502)
	at org.eclipse.core.launcher.Main.main(Main.java:362)

I believe that Main cannot find one of the following classes (snippet copied
from Main):
	private static final String PI_BOOT = "org.eclipse.core.boot";
	private static final String BOOTLOADER =
"org.eclipse.core.boot.BootLoader";
	private static final String UPDATELOADER =
"org.eclipse.core.internal.boot.LaunchInfo";

I copied all /usr/eclipse/plugin/<path>/*.jar files into
/usr/java/jdk1.3.1/jre/lib/ext, but got the same result.

I looked in the eclipse-dev archive, but could not find any clarification.
I have looked into the ../eclipse/readme/running.html but that did not make
me much wiser.

Can somebody give me a hint what I should do.

Many thanks,
Wout Perquin

BTW I also downloaded eclipse-SDK-20011206-win32 and installed it on Windows
98.  That works ok.