[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [eclipse-dev] Comment on Eclipse Project 2.0 DRAFT plan: Workspace compatibility

Are you planning to prepare the next draft of the plan document, or would 
you like me to do the editing? 
---jim





John_Wiegand@xxxxxxx
Sent by: eclipse-dev-admin@xxxxxxxxxxx
12/10/01 10:51 AM
Please respond to eclipse-dev

 
        To:     eclipse-dev@xxxxxxxxxxx
        cc: 
        Subject:        Re: [eclipse-dev] Comment on Eclipse Project 2.0 DRAFT plan: Workspace 
compatibility

This is an accurate observation.  We will revise the plan to make this 
more clear.
There are two areas where upgrading cannot be transparent:
1. "eclipse" project plugins that had provisional API in 1.0.  Metadata in 

these plugins will likely 
not be compatible with 2.0. 
2. all non-"eclipse" project plugins will need to handle this problem. 
(The platform cannot upgrade
metadata in a general purpose way).

The guidelines requested below are not available, but it is a good idea.




manahan@xxxxxxxxxx
Sent by: eclipse-dev-admin@xxxxxxxxxxx
12/08/2001 02:19 PM
Please respond to eclipse-dev

 
        To:     eclipse-dev@xxxxxxxxxxx
        cc: 
        Subject:        [eclipse-dev] Comment on Eclipse Project 2.0 DRAFT 
plan: Workspace 
compatibility

Hi, is the following statement only viable for "eclipse" project plugins 
(I
expect that what was meant, just for clarity). There are many plugins out
there which make use/create metadata in the workspace. Are (there/will
there be) guidelines on how to make use of metadata in the workspace in
order to have a successful upgrade to a 2.0 workspace as described.? If 
not
you may want to add a disclaimer as people may expect eclipse to be
handling most of their migration issues.

-----------------------------------------------------------------
Workspace Compatibility: Eclipse 2.0 will be upwards workspace-compatible
with Eclipse 1.0 unless noted. This means that workspaces and projects
created with Eclipse 1.0 can be successfully opened by Eclipse 2.0 and
upgraded to a 2.0 workspace. Downward workspace compatibility is not
supported. A workspace created (or opened) by Eclipse 2.0 will be unusable
with an earlier version of Eclipse.
----------------------------------------------------------------

Thanks,
_____________________________________
Peter Manahan
WSAD Linux Port Team
VisualAge for Java Release Lead
manahan@xxxxxxxxxx
_____________________________________

_______________________________________________
eclipse-dev mailing list
eclipse-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/eclipse-dev



_______________________________________________
eclipse-dev mailing list
eclipse-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/eclipse-dev