[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[eclipse-dev] Comment on Eclipse Project 2.0 DRAFT plan: Workspace compatibility

Hi, is the following statement only viable for "eclipse" project plugins (I
expect that what was meant, just for clarity). There are many plugins out
there which make use/create metadata in the workspace. Are (there/will
there be) guidelines on how to make use of metadata in the workspace in
order to have a successful upgrade to a 2.0 workspace as described.? If not
you may want to add a disclaimer as people may expect eclipse to be
handling most of their migration issues.

-----------------------------------------------------------------
Workspace Compatibility: Eclipse 2.0 will be upwards workspace-compatible
with Eclipse 1.0 unless noted. This means that workspaces and projects
created with Eclipse 1.0 can be successfully opened by Eclipse 2.0 and
upgraded to a 2.0 workspace. Downward workspace compatibility is not
supported. A workspace created (or opened) by Eclipse 2.0 will be unusable
with an earlier version of Eclipse.
----------------------------------------------------------------

Thanks,
_____________________________________
Peter Manahan
WSAD Linux Port Team
VisualAge for Java Release Lead
manahan@xxxxxxxxxx
_____________________________________