[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [eclipse-dev] Eclipse on Linux/390 and SWT shared library

You need swt.c, which apparently wasn't included in last night's build.
Here's a pointer to what you'll need in your
...plugins/org.eclipse.swt/Eclipse SWT/motif/library directory, including
swt.c:


http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.swt/Eclipse%20SWT/motif/library/

Grant



                                                                                                                         
                    "Stephen Henkels"                                                                                    
                    <henkels@xxxxxxxxxx        To:     eclipse-dev@xxxxxxxxxxx                                           
                    >                          cc:                                                                       
                    Sent by:                   Subject:     Re: [eclipse-dev] Eclipse on Linux/390 and SWT shared        
                    eclipse-dev-admin@e        library                                                                   
                    clipse.org                                                                                           
                                                                                                                         
                                                                                                                         
                    11/16/2001 02:00 PM                                                                                  
                    Please respond to                                                                                    
                    eclipse-dev                                                                                          
                                                                                                                         
                                                                                                                         




In one of the earlier versions we had found the source for this but it is
not in the official release in the
 eclipse/plugins/org.eclipse.swt   subtree ....... does anyone know where
or from whom I can get the
source to build
/eclipse/eclipse/plugins/org.eclipse.swt/ws/motif/libswt-linux-2012.so ??

Steve


"James Moody/OTT/OTI" <James_Moody@xxxxxxx>@eclipse.org on 11/16/2001
10:54:52 AM

Please respond to eclipse-dev@xxxxxxxxxxx

Sent by:    eclipse-dev-admin@xxxxxxxxxxx


To:    eclipse-dev@xxxxxxxxxxx
cc:
Subject:    Re: [eclipse-dev] Eclipse on Linux/390



The folks on the SWT mailing list would probably be able to help you out.
You need to rebuild the swt shared library which contains the JNI bindings
to the motif implementation. As far as I know it should be a straight
recompile,
someone more knowledgeable can tell you if there are other issues, and
how to properly build it.

james





"Stephen Henkels" <henkels@xxxxxxxxxx>
Sent by: eclipse-dev-admin@xxxxxxxxxxx
11/16/2001 10:48 AM
Please respond to eclipse-dev


        To:     eclipse-dev@xxxxxxxxxxx
        cc:
        Subject:        [eclipse-dev] Eclipse on Linux/390


I tried to bring up eclipse on Linux/390 and see that there are some
executables which are Intel only .... since 390 is BigEndian the loader
rejects with
a message ....... How much non-java code would I have to re-build to get
the shared object below ........ I built the motif version on Linux/390
using build.csh ....  I am able to get the splash screen up on my
x-server.... but then see this message...... so I guess the swt needs
re-build too ??

java.lang.UnsatisfiedLinkError:
/eclipse/eclipse/plugins/org.eclipse.swt/ws/motif/libswt-linux-2012.so:
/eclipse/eclipse/plugins/org.eclipse.swt/ws/motif/libswt-linux-2012.so:
ELF
file data encoding not big-endian

The verbose java output of eclipse is in the following file (See attached
file: out)

Maybe using a Linux/390 is not a good fit for devlopment environement, but
I know folks will want to try it anyway .......... I have the latest
Linux/390 1.3.0 version
on my 2.4.7 (SuSE new 7.2 distro for L/390)

Thanks, Steve





_______________________________________________
eclipse-dev mailing list
eclipse-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/eclipse-dev



_______________________________________________
eclipse-dev mailing list
eclipse-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/eclipse-dev