[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Oxygen.1a is broken when installed on top of the BETA Patch feature

On 10/13/2017 06:04 PM, Stephan Herrmann wrote:
On day 2 after the Oxygen.1a there was quite a disastrous report on SO:

https://stackoverflow.com/questions/46731161/jdk-9-wont-let-me-use-strings-java-lang-string-is-ambiguous


It turned out to be a "simple" installation problem, and I'm afraid that many users will run into this, too:

Installing Oxygen.1a on top of the BETA Patch feature does not
effectively install the released version of JDT plug-ins.

I believe this needs to be communicated immediately to all those
who previously installed the patch feature.

Which channel?
I don't know, "check for updates" doesn't have a web page ...

Stephan

PS: needless to say, that the RC2a respin is also without effect in this setting.

= = =

I have not looked at this in detail, but one solution would be to produce a new "Beta Java-9 patch" even though it is no longer needed with Oxygen.1.

Its purpose would be to simply make sure the latest JDT was installed (instead of the patched parts of JDT).

The idea is that if someone has the beta patch installed already, then "check for updates" would effectively pull in Oxygen 1a.