[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Oxygen.1aRC1: Maven fails with org.codehaus.plexus.classworlds.launcher.Launcher when running with JDK 9

Ah, Java Development Tools Launching Support is at 3.9.50.v2070925-1051 in that latest EPP build which might just not yet include the fix from the same day.

 

Von: cross-project-issues-dev-bounces@xxxxxxxxxxx [mailto:cross-project-issues-dev-bounces@xxxxxxxxxxx] Im Auftrag von Fred Bricon
Gesendet: Mittwoch, 4. Oktober 2017 16:04
An: Cross project issues
Betreff: Re: [cross-project-issues-dev] Oxygen.1aRC1: Maven fails with org.codehaus.plexus.classworlds.launcher.Launcher when running with JDK 9

 

I'll see if I can workaround it on m2e's side for RC2. Not promising any miracles though.

 

Fred

 

On Wed, Oct 4, 2017 at 9:55 AM, Arthur van Dorp <Arthur.vanDorp@xxxxxxxxxxxxxxxx> wrote:

Thanks. Didnât come up in my bugzilla searches as it is marked fixed.

Doesnât seem fixed to me.

 

Regards

Arthur

 

Von: cross-project-issues-dev-bounces@xxxxxxxxxxx [mailto:cross-project-issues-dev-bounces@xxxxxxxxxxx] Im Auftrag von Fred Bricon
Gesendet: Mittwoch, 4. Oktober 2017 15:48
An: Cross project issues
Betreff: Re: [cross-project-issues-dev] Oxygen.1aRC1: Maven fails with org.codehaus.plexus.classworlds.launcher.Launcher when running with JDK 9

 

 

On Wed, Oct 4, 2017 at 9:26 AM, Arthur van Dorp <Arthur.vanDorp@xxxxxxxxxxxxxxxx> wrote:

Hi all

 

As the RC2 window already closes and the final Oxygen.1a contributions are due soon, I bring up the following issue directly on this list:

 

On the EPP RC1 with only a JDK 9 as installed JRE, calling Maven commands fails with

Error: Could not find or load main class org.codehaus.plexus.classworlds.launcher.Launcher

Caused by: java.lang.ClassNotFoundException: org.codehaus.plexus.classworlds.launcher.Launcher

Switching to a JDK 8 resolves the problem.

 

Steps to reproduce:

*New workspace

*File/New Otherâ/Maven/Maven Project/Create dummy project

*Select project folder/Right click/Run Asâ/Maven clean

 

Iâve reproduced this under Windows 7 and the Scout EPP package. To make sure it isnât a Scout issue Iâve tested with a post RC1 EPP package of Eclipse Java too.

 

Has anyone else experienced this? Is anyone else able to reproduce it?

 

Thanks and regards

Arthur

 


_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev



 

--

"Have you tried turning it off and on again" - The IT Crowd

And if that fails, then http://goo.gl/tnBgH5


_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev



 

--

"Have you tried turning it off and on again" - The IT Crowd

And if that fails, then http://goo.gl/tnBgH5

Attachment: smime.p7s
Description: S/MIME cryptographic signature