[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Oxygen.1 and JDK9

Ok then I am lost .. which steps did you mean?

Pre-requisite:

ÂÂÂ You need Oxygen (4.7 or above)Â Eclipse SDK or maintenance(M) builds (available from http://download.eclipse.org/eclipse/downloads/)Â <- got that
 The Javaâ 9 support also works when the IDE is launched with a Javaâ 8 VM. There is no need to switch Javaâ 9 VM for that. <-- ok tried both
 For any Eclipse install <= Oxygen 1 you have to add --add-modules=ALL-SYSTEM. For more details and potential issues see https://wiki.eclipse.org/Configure_Eclipse_for_Java_9. <-- did that as well
ÂÂÂ You need Javaâ 9 JDK ( Available from the JDK9 pointer at the parent site: http://www.oracle.com/technetwork/java/javase/downloads/index.html) <-- check

To try out Java 9 support in Eclipse, you can follow any of these:

ÂÂÂ Update your Eclipse 4.7 build using this update site: http://download.eclipse.org/eclipse/updates/4.7-U-builds. In Eclipse, go to Help > Install New Software... and uncheck "Group items by category". Select "Eclipse SDK" from the list of items and proceed with the installation.ÂÂ <!-- didn't do that .. but I can use "any" of these
ÂÂÂ Update your Eclipse 4.7 build for committers (https://www.eclipse.org/downloads/packages/eclipse-ide-eclipse-committer...) using Eclipse Marketplace entry (currently, needs some additional steps):ÂÂ <-- went with that one

 Drag and drop the Install button on this web page to your running Eclipse workspace. This will open the Eclipse Marketplace dialog. <-- dialog open
 Click the link "One solution selected" at the bottom. <-- doesn't appear .. so the next bullet steps are not working either
ÂÂÂ In the Java 9 support entry, press "Update Pending" button.
ÂÂÂ Press the same button again, now named "Update". Ignore the progress bar message at the bottom.
ÂÂÂ On the next page which comes up, make sure "Update my installation..." is selected and press "Confirm".
ÂÂÂ Accept the license and proceed with the installation.

I did install Eclipse Comitters edition with the Eclipse Installer, maybe that is an issue?

On Thu, Sep 28, 2017 at 11:13 AM, Daniel Megert <daniel_megert@xxxxxxxxxx> wrote:
That sounds like you did not exactly follow the steps listed on the MPE. I just tried again and could install it into the committers package.

Dani



From: Â Â Â ÂJens Reimann <jreimann@xxxxxxxxxx>
To: Â Â Â ÂCross project issues <cross-project-issues-dev@eclipse.org>
Date: Â Â Â Â28.09.2017 10:38
Subject: Â Â Â ÂRe: [cross-project-issues-dev] Oxygen.1 and JDK9
Sent by: Â Â Â Âcross-project-issues-dev-bounces@xxxxxxxxxxx




I tried that as well, however this only brings up the marketplace client and shows you a generic list of things to install.

If you locate the Java 9 feature, then it says "Installed". But there is no way to actually install this.

I really think there should be some note on download.eclipse.orgwhich explains that people have to wait for Oxygen.1a, otherwise this may just cause frustration.

Jens

On Thu, Sep 28, 2017 at 10:26 AM, Daniel Megert <daniel_megert@xxxxxxxxxx> wrote:
> You have to install the Java9 support from the Eclipse Marketplace into it.

See
https://marketplace.eclipse.org/content/java-9-support-oxygen/

Dani





From: Â Â Â Â
Martin Lippert <mlippert@xxxxxxxxx>
To: Â Â Â Â
Cross project issues <cross-project-issues-dev@eclipse.org>
Date: Â Â Â Â
28.09.2017 10:17
Subject: Â Â Â Â
Re: [cross-project-issues-dev] Oxygen.1 and JDK9
Sent by: Â Â Â Â
cross-project-issues-dev-bounces@xxxxxxxxxxx





Hey Jens,

Oxygen.1 does NOT support Java 9 development out-of-the-box.
You have to install the Java9 support from the Eclipse Marketplace into it.

This will change with Oxygen.1a (shipping Oct 11), which will include Java9 support ouf-of-the-box.

Hope this helps!

Cheers,
-Martin



> I got some troubles on getting Oxygen.1 ready for Java 9 ... I don't want to run Oxygen.1 on Java 9, but use it on Java 8, to develop a Java 9 application. Or at least, run a Java 8 application from inside the IDE on Java 9.
>
> Here is what I did:
>
> * Update my Oxygen to Oxgyen.1 (or install a new Oxygen.1)
> * Download and unzip JDK9 (oracle & openjdk)
> * Point the JVM preferences page to my unzipped JDK9
>
> The error message is:
>
> Â-> Target is not a JDK root. System library was not found.
>
> Now I maybe doing something wrong here, but neither Google nor any Eclipse Java 9 page I found did explain this.
>
> I also tried running Oxygen.1 on Java 9, same effect.
>
> Thanks for your help
>
> Jens
>
> --
> Jens Reimann
> Senior Software Engineer / EMEA ENG Middleware
> Werner-von-Siemens-Ring 14
> 85630 Grasbrunn
> Germany
> phone:
+49 89 2050 71286
> _____________________________________________________________________________
>
> Red Hat GmbH,
www.de.redhat.com
,

> Registered seat: Grasbrunn, Commercial register: Amtsgericht Muenchen, HRB 153243,
> Managing Directors: Paul Argiry, Charles Cachera, Michael Cunningham, Michael O'Neill
> _______________________________________________
> cross-project-issues-dev mailing list
>
cross-project-issues-dev@eclipse.org
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit

> https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_cross-2Dproject-2Dissues-2Ddev&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=1UITCR5rxUZHSFczvfaNFK4ymEbEiccRX7VKchpqz0Y&m=Ru_XrVVgIKJT1JZ8X0XlhXveK-kqmvo48FrJkW0BEgI&s=RcwZjx50dyvyv9lr58K7KJPiRnSIY1cXPay4bSqWezc&e=

_______________________________________________
cross-project-issues-dev mailing list

cross-project-issues-dev@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_cross-2Dproject-2Dissues-2Ddev&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=1UITCR5rxUZHSFczvfaNFK4ymEbEiccRX7VKchpqz0Y&m=Ru_XrVVgIKJT1JZ8X0XlhXveK-kqmvo48FrJkW0BEgI&s=RcwZjx50dyvyv9lr58K7KJPiRnSIY1cXPay4bSqWezc&e=





_______________________________________________
cross-project-issues-dev mailing list

cross-project-issues-dev@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev



--

Jens Reimann
Senior Software Engineer / EMEA ENG Middleware
Werner-von-Siemens-Ring 14
85630 Grasbrunn
Germany
phone: +49 89 2050 71286
_____________________________________________________________________________

Red Hat GmbH,
www.de.redhat.com
,

Registered seat: Grasbrunn, Commercial register: Amtsgericht Muenchen, HRB 153243,
Managing Directors: Paul Argiry, Charles Cachera, Michael Cunningham, Michael O'Neill
_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_cross-2Dproject-2Dissues-2Ddev&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=1UITCR5rxUZHSFczvfaNFK4ymEbEiccRX7VKchpqz0Y&m=BtDqGiJSjWAZtbVmMdKPeEo7Vchrqn7VOABNgM9vY1E&s=Zi0iEsIQhjuVgt3KgGhj-7cHLF3wo-nsiCXV_BY6UEE&e=



_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev



--
Jens Reimann
Senior Software Engineer / EMEA ENG Middleware
Werner-von-Siemens-Ring 14
85630 Grasbrunn
Germany
phone: +49 89 2050 71286
_____________________________________________________________________________

Red Hat GmbH, www.de.redhat.com,
Registered seat: Grasbrunn, Commercial register: Amtsgericht Muenchen, HRB 153243,
Managing Directors: Paul Argiry, Charles Cachera, Michael Cunningham, Michael O'Neill