[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Eclipse simrel aggregation broken

Fine by us; our contribution for Photon M2 is still building (that will be compatible with Xtext 2.13).

ZoltÃn
-- ZoltÃn Ujhelyi

Eclipse Technologies Expert
IncQueryLabs Ltd.

> On 2017. Sep 20., at 8:59, Dennis HÃbner <dennis.huebner@xxxxxxxxxx> wrote:
> 
> Hi,
> I will disable all the not compatible contributions (Viatra) right now and push the fix.
> 
> Kind regards,
> Dennis.
> 
> 
>> Am 20.09.2017 um 08:57 schrieb ZoltÃn Ujhelyi <zoltan.ujhelyi@xxxxxxxxxxxxxxxx>:
>> 
>> Hi,
>> 
>> thanks for the heads up. If next time VIATRA blocks your build, feel free to disable it, and notify us to fix it. This way at least we wonât block other projects from building their contributions into simrel.
>> 
>> Best regards,
>> ZoltÃn
>> -- ZoltÃn Ujhelyi
>> 
>> Eclipse Technologies Expert
>> IncQueryLabs Ltd.
>> 
>>> On 2017. Sep 20., at 8:18, Dennis HÃbner <dennis.huebner@xxxxxxxxxx> wrote:
>>> 
>>> Hi guys,
>>> 
>>> we updated to version 2.13 as you noticed.
>>> I donât see an another way to contribute before +3 projects
>>> 
>>> Sorry for the caused inconvenience
>>> 
>>> Regards,
>>> Dennis.
>>> 
>>> 
>>>> Am 19.09.2017 um 22:08 schrieb Ãbel HegedÃs <abel.hegedus@xxxxxxxxxxxxxxxx>:
>>>> 
>>>> Also, it seems eclipse@xxxxxxxxxx does not exist, so it should not be present in the aggrcon files.
>>>> -----
>>>> Ãbel HegedÃs
>>>> 
>>>> IncQuery Labs Ltd.
>>>> From: Ãbel HegedÃs
>>>> Sent: Tuesday, September 19, 2017 10:06:08 PM
>>>> To: Wenz, Michael; dennis.huebner@xxxxxxxxxx; eclipse@xxxxxxxxxx
>>>> Cc: ZoltÃn Ujhelyi
>>>> Subject: Re: Eclipse simrel aggregation broken
>>>> 
>>>> It seems Xtext has contributed 2.13.0M2 without goind through Gerrit:
>>>> https://git.eclipse.org/c/simrel/org.eclipse.simrel.build.git/commit/?id=e010159c7b3052f4695be1e156859203b8a8b742
>>>> https://git.eclipse.org/r/#/q/project:simrel/org.eclipse.simrel.build
>>>> 
>>>> Of course we will update the VIATRA contribution to accept Xtext 2.13, probably as early as tomorrow.
>>>> 
>>>> If you are blocked, I suggest reverting the above commit.
>>>> 
>>>> Best regards,
>>>> -----
>>>> Ãbel HegedÃs
>>>> 
>>>> IncQuery Labs Ltd.
>>>> From: Wenz, Michael <michael.wenz@xxxxxxx>
>>>> Sent: Tuesday, September 19, 2017 8:31:00 PM
>>>> To: dennis.huebner@xxxxxxxxxx; eclipse@xxxxxxxxxx
>>>> Cc: Ãbel HegedÃs; ZoltÃn Ujhelyi
>>>> Subject: RE: Eclipse simrel aggregation broken
>>>> 
>>>> Sorry, I forgot to add the link to my Gerrit change for the Graphiti contribution file:
>>>> https://git.eclipse.org/r/#/c/105360/
>>>> 
>>>> 
>>>> From: Wenz, Michael 
>>>> Sent: Dienstag, 19. September 2017 20:30
>>>> To: 'dennis.huebner@xxxxxxxxxx' <dennis.huebner@xxxxxxxxxx>; 'eclipse@xxxxxxxxxx' <eclipse@xxxxxxxxxx>
>>>> Cc: 'abel.hegedus@xxxxxxxxxxxxxxxx' <abel.hegedus@xxxxxxxxxxxxxxxx>; 'ujhelyiz@xxxxxxxxxxxxxxxx' <ujhelyiz@xxxxxxxxxxxxxxxx>
>>>> Subject: Eclipse simrel aggregation broken
>>>> 
>>>> Hi Dennis,
>>>> 
>>>> I tried to push our Graphiti contribution change for Photo M2 but during the Gerrit voter run get the following error:
>>>> Cannot complete the install because one or more required items could not be found. Software being installed: validationSet_main 1.0.0 Missing requirement: org.eclipse.viatra.query.patternlanguage 1.7.0.201708091110 requires 'bundle org.eclipse.xtext.xbase [2.9.0,2.13.0)' but it could not be found Cannot satisfy dependency: mappedRepo_home_data_httpd_download.eclipse.org_viatra_updates_milestone_1.7.0.201708091110 1.0.0 depends on: org.eclipse.viatra.query.sdk.feature.source.feature.group [1.7.0.201708091110] Cannot satisfy dependency: org.eclipse.viatra.query.language.feature.feature.group 1.7.0.201708091110 depends on: org.eclipse.viatra.query.patternlanguage [1.7.0.201708091110] Cannot satisfy dependency: org.eclipse.viatra.query.sdk.feature.feature.group 1.7.0.201708091110 depends on: org.eclipse.viatra.query.language.feature.feature.group [1.7.0.201708091110] Cannot satisfy dependency: org.eclipse.viatra.query.sdk.feature.source.feature.group 1.7.0.201708091110 depends on: org.eclipse.viatra.query.sdk.feature.feature.group [1.7.0.201708091110] Cannot satisfy dependency: validationSet_main 1.0.0 depends on: mappedRepo_home_data_httpd_download.eclipse.org_viatra_updates_milestone_1.7.0.201708091110 [1.0.0]
>>>> [0]Missing requirement: VIATRA Base Query Language 1.7.0.201708091110 (org.eclipse.viatra.query.patternlanguage 1.7.0.201708091110) requires 'bundle org.eclipse.xtext.xbase [2.9.0,2.13.0)' but it could not be found
>>>> 
>>>> Bundle(org.eclipse.xtext.xbase [2.9.0,2.13.0)) is required by:
>>>> ValidationSet(main)
>>>>   Contribution(VIATRA)
>>>>     MappedRepository(file:/home/data/httpd/download.eclipse.org/viatra/updates/milestone/1.7.0.201708091110)
>>>>       Feature(org.eclipse.viatra.query.sdk.feature.source.feature.group [1.7.0.201708091110,1.7.0.201708091110])
>>>>         InstallableUnit(org.eclipse.viatra.query.sdk.feature.feature.group 1.7.0.201708091110)
>>>>           InstallableUnit(org.eclipse.viatra.query.language.feature.feature.group 1.7.0.201708091110)
>>>>             InstallableUnit(org.eclipse.viatra.query.patternlanguage 1.7.0.201708091110)
>>>> 
>>>> 
>>>> I saw that you increased xText version with commit e010159c7b3052f4695be1e156859203b8a8b742; it looks as if that broke the viatra contribution. Could you double check?
>>>> 
>>>> I ccâed the viatra contactsâ
>>>> 
>>>> Thanks,
>>>> Michael
>>> 
>>> Dennis HÃbner
>>> 
>>> TypeFox GmbH
>>> Am Germaniahafen 1
>>> 24143 Kiel
>>> 
>>> Sitz: Kiel, Registergericht: Amtsgericht Kiel, HRB 17385
>>> Managing Directors: Sven Efftinge, Moritz Eysholdt, Dr. Jan KÃhnlein
>>> 
>> 
> 
> Dennis HÃbner
> 
> TypeFox GmbH
> Am Germaniahafen 1
> 24143 Kiel
> 
> Sitz: Kiel, Registergericht: Amtsgericht Kiel, HRB 17385
> Managing Directors: Sven Efftinge, Moritz Eysholdt, Dr. Jan KÃhnlein
>