[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[cross-project-issues-dev] Viatra is failing to aggregate for Photon M2 since xtext updated

Xtext updated to 2.13.0.  This appears to cause Viatra to fail because
it has OSGI range: [2.9.0,2.13.0)

Cannot complete the install because one or more required items could
not be found. Software being installed: validationSet_main 1.0.0
Missing requirement: org.eclipse.viatra.query.patternlanguage
1.7.0.201708091110 requires 'bundle org.eclipse.xtext.xbase
[2.9.0,2.13.0)'

Not sure how the Xtext change went through gerrit validation, but I
cannot push Linux Tools for Photon M2.

There is another error with EMF Parsley which might be related, but I
don't have the details at the moment.

-- Jeff J.