[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] [eclipse.org-planning-council] Neon.3 Update Problems

On 03/31/2017 09:25 AM, Ed Willink wrote:

Hi

It is currently necessary to rebundle Orbit bundles because Orbit is not included in the xxx release repo.

One can (and should) include the Orbit bundles in the p2 repo, but not include them in the feature. So the dependencies are available at install-time, but not constraining the resolution. The category.xml easily allows to add any bundle to a p2 repo, those could be Orbit ones.

--
Mickael Istria
Eclipse developer for Red Hat Developers
My blog - My Tweets