[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[cross-project-issues-dev] Fwd: Problems with Simrel contribution

Hello,

I'm forwarding the following thread of discussion since seems that previous messages were not delivered to the list - "being held until the list moderator can review it for approval. The reason it is being held: Too many recipients to the message"

And an update on subject:
EclEmma has been re-enabled to unblock work of Andreas Sewe on https://git.eclipse.org/r/#/c/84521/
Papyrus really seems to be a cause of a problem, because after re-enablement all builds are still green.

Regards,
Evgeny

---------- Forwarded message ---------
From: Evgeny Mandrikov <mandrikov@xxxxxxxxx>
Date: Fri, Mar 10, 2017 at 1:46 PM
Subject: Re: Problems with Simrel contribution
To: GrÃgoire DUPE <gdupe@xxxxxxxxxxxxxxxx>, Sravan K Lakkimsetti <sravankumarl@xxxxxxxxxx>, jfaltermeier@xxxxxxxxxxxxxxxxx <jfaltermeier@xxxxxxxxxxxxxxxxx>, emueller@xxxxxxxxxxxxxxxxx <emueller@xxxxxxxxxxxxxxxxx>, stepper@xxxxxxxxxx <stepper@xxxxxxxxxx>, cedric.brun@xxxxxxx <cedric.brun@xxxxxxx>, laurent.goubet@xxxxxxx <laurent.goubet@xxxxxxx>, lorenzo.bettini@xxxxxxxxx <lorenzo.bettini@xxxxxxxxx>, vincenzo.caselli@xxxxxxxxxxxxxx <vincenzo.caselli@xxxxxxxxxxxxxx>, francesco.guidieri@xxxxxxxxx <francesco.guidieri@xxxxxxxxx>, francois.le-fevre@xxxxxx <francois.le-fevre@xxxxxx>, quentin.lemenez@xxxxxx <quentin.lemenez@xxxxxx>, vincent.lorenzo@xxxxxx <vincent.lorenzo@xxxxxx>, stephaneberle9@xxxxxxxxx <stephaneberle9@xxxxxxxxx>, Frederic Gurr <frederic.gurr@xxxxxxxxxxx>
Cc: Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>


Hi,

FWIW I come to exactly the same conclusion.

On Fri, Mar 10, 2017 at 1:24 PM GrÃgoire DUPE <gdupe@xxxxxxxxxxxxxxxx> wrote:

Hello,

Â

Itâs looks like that the problem comes from âorg.eclipse.papyrus.infra.widgetsâ which has the following dependency : org.eclipse.e4.ui.model.workbench [1.2.0,2.0.0) (cf. the error message at the end of this e-mail)

Â

Can anybody from Papyrus check that ?

Â

Regards,

GrÃgoire

Â

Cannot complete the install because of a conflicting dependency.

Software being installed: validationSet_main 1.0.0

Only one of the following can be installed at once: [org.eclipse.e4.ui.model.workbench 2.0.0.v20170228-1842, org.eclipse.e4.ui.model.workbench 1.3.0.v20170105-1239]

Cannot satisfy dependency: mappedRepo_download.eclipse.org_eclipse_updates_4.7milestones_S-4.7M6-201703082000 1.0.0 depends on: org.eclipse.platform.ide 0.0.0

Cannot satisfy dependency: mappedRepo_download.eclipse.org_modeling_mdt_papyrus_updates_milestones_3.0_M5_main 1.0.0 depends on: org.eclipse.papyrus.sdk.feature.feature.group 3.0.0

Cannot satisfy dependency: org.eclipse.papyrus.infra.widget.feature.feature.group 3.0.0.201702011724 depends on: org.eclipse.papyrus.infra.widgets [3.0.0.201702011724]

Cannot satisfy dependency: org.eclipse.papyrus.infra.widgets 3.0.0.201702011724 depends on: bundle org.eclipse.e4.ui.model.workbench [1.2.0,2.0.0)

Cannot satisfy dependency: org.eclipse.papyrus.sdk.feature.feature.group 3.0.0.201702011724 depends on: org.eclipse.papyrus.infra.widget.feature.feature.group [3.0.0.201702011724]

Cannot satisfy dependency: org.eclipse.platform.feature.group 4.7.0.v20170308-2000 depends on: org.eclipse.ui.ide [3.13.0.v20170306-1626]

Cannot satisfy dependency: org.eclipse.platform.ide 4.7.0.I20170308-2000 depends on: org.eclipse.platform.feature.group [4.7.0.v20170308-2000]

Cannot satisfy dependency: org.eclipse.ui.ide 3.13.0.v20170306-1626 depends on: bundle org.eclipse.e4.ui.model.workbench [2.0.0,3.0.0)

Cannot satisfy dependency: validationSet_main 1.0.0 depends on: mappedRepo_download.eclipse.org_eclipse_updates_4.7milestones_S-4.7M6-201703082000 [1.0.0]

Cannot satisfy dependency: validationSet_main 1.0.0 depends on: mappedRepo_download.eclipse.org_modeling_mdt_papyrus_updates_milestones_3.0_M5_main [1.0.0]

Only one of the following can be installed at once:

ÂÂEclipse Workbench Model 2.0.0.v20170228-1842 (org.eclipse.e4.ui.model.workbench 2.0.0.v20170228-1842)

 Eclipse Workbench Model 1.3.0.v20170105-1239 (org.eclipse.e4.ui.model.workbench 1.3.0.v20170105-1239)

Â

bundle(org.eclipse.e4.ui.model.workbench 2.0.0.v20170228-1842) is required by:

 ValidationSet(main)

ÂÂÂ Contribution(Eclipse)

ÂÂÂÂÂ MappedRepository(http://download.eclipse.org/eclipse/updates/4.7milestones/S-4.7M6-201703082000/)

ÂÂÂÂÂÂÂ Product(org.eclipse.platform.ide)

ÂÂÂÂÂÂÂÂÂ InstallableUnit(org.eclipse.platform.feature.group 4.7.0.v20170308-2000)

ÂÂÂÂÂÂÂÂÂÂÂ InstallableUnit(org.eclipse.ui.ide 3.13.0.v20170306-1626)

bundle(org.eclipse.e4.ui.model.workbench 1.3.0.v20170105-1239) is required by:

 ValidationSet(main)

ÂÂÂ Contribution(Papyrus)

ÂÂÂÂÂ MappedRepository(http://download.eclipse.org/modeling/mdt/papyrus/updates/milestones/3.0/M5/main)

ÂÂÂÂÂÂÂ Feature(org.eclipse.papyrus.sdk.feature.feature.group 3.0.0)

ÂÂÂÂÂÂÂÂÂ InstallableUnit(org.eclipse.papyrus.infra.widget.feature.feature.group 3.0.0.201702011724)

ÂÂÂÂÂÂÂÂÂÂÂ InstallableUnit(org.eclipse.papyrus.infra.widgets 3.0.0.201702011724)

Â

Â

Â

Â

Â

Hi,

Â

I am doing simrel contribution for 4.7 M6 for platform and equinox. During this process. I found that the following projects are not compatible anymore. I have disabled these projects with my contribution. My request is to re-enable them during your contribution to 4.7 M6.

Â

The projects that were disabled.

  1. EclEmma
  2. ECP
  3. EMF CDO
  4. EMF COMPARE
  5. EMF Parsley
  6. MoDisco
  7. Papyrus
  8. Sphinx

Â

Thanks and Regards,

Sravan

Â

Sravan Kumar Lakkimsetti

IBM India Pvt Ltd,

Embassy Golf Links Business Park, D Block,

Off Indiranagar-Kormangla Inner Ring Road,

Bangalore - 560071, India

Phone: 91-80-41776858

Â

Â