[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] core.jobs dependency on Java 8

In our PMC call today [1] we decided to move 'org.eclipse.core.jobs' back to JavaSE-1.7.

[1] https://wiki.eclipse.org/Eclipse/PMC#Meeting_Minutes

Dani



From:        Ralf Sternberg <rsternberg@xxxxxxxxxxxxxxxxx>
To:        Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>
Date:        08.12.2015 00:21
Subject:        Re: [cross-project-issues-dev] core.jobs dependency on Java 8
Sent by:        cross-project-issues-dev-bounces@xxxxxxxxxxx




Hi John,

thanks for your support.

> One question for you Ralf, is whether this is the only bundle RAP requires
> that is blocking you in this way? I thought there were a number of other
> platform bundles already requiring Java 8 as well.

Unfortunately, as Ivan reported already, there are three more
eclipse.core.databinding bundles now requiring Java 8 that I was not
aware of. All other dependencies of RAP (equinox, eclipse.core,
javax.servlet, javax.xml, icu) are still on <= 1.7.

As Lars pointed out in bug 483803, the planned support for the new
Date and Time API would require Java 8, so the core.databinding
bundles should remain on Java 8. I'd think that the databinding
bundles are less critical for us as databinding is an optional feature
and the bundles could probably easily be replaced by their Mars
versions in a Java 7 deployment.

Also thanks to Thomas and Konstantin for the pointers to Application
Servers and Java 8. We'll discuss again if moving to Java 8 could
already be an option for RAP 3.1.

Regards,
Ralf
_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev