[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[cross-project-issues-dev] Announcing JDK 9 support for Eclipse Neon

Hello everyone,

On behalf of the Eclipse team, I would like to share with everyone about the beta support for JDK 9 in Eclipse SDK. The update, which is called "Eclipse Javaâ 9 Support (BETA) for Neon", can be installed from the following update site or Eclipse Marketplace client. You need Eclipse M2 (build I20150916-2000) or later to install the update successfully. Also note that you need to run Eclipse with JRE 8 or 9 to receive the benefits of the update.

http://download.eclipse.org/eclipse/updates/4.6-P-builds

At this point, I would like to call out that JDK 9 is unlike any other JDK versions of the past, notable change being the JAR files (with platform classes) are giving way to a proprietary format. This update is not to be confused with Java 9 support, though, which is about Java modules.

Regards,
Jay