[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cross-project-issues-dev] Clarification on EE specification in practice


I missed one point about TPTP model plugin, although we specify that it can run on J2SE-1.4, because Europa won't provide EMF 2.2.2 (that's my understanding) our plugin (and because of it most of TPTP) won't work on J2SE-1.4 when installed from Europa update site (I assume it can be installed on J2SE-1.4, although I don't know how the update manager will actually handle this case, it might ignore TPTP model plugin just because it needs a bundle that cannot work on J2SE-1.5, in this case EMF 2.3.0 being the only one available).

Thanks !

Marius Slavescu
IBM Toronto Laboratory, Canada
Phone: 905-413-3610





Marius Slavescu/Toronto/IBM@IBMCA
Sent by: cross-project-issues-dev-bounces@xxxxxxxxxxx

01/17/2007 11:38 AM

Please respond to
Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>

To
Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>
cc
Subject
Re: [cross-project-issues-dev] Clarification on EE specification in        practice






Please read on first line:

"basically you need to test your code against that environment.
"

and bellow:

"I've asked before if Europa will have a preferred"


Thanks !

Marius Slavescu
IBM Toronto Laboratory, Canada
Phone: 905-413-3610




Marius Slavescu/Toronto/IBM@IBMCA
Sent by: cross-project-issues-dev-bounces@xxxxxxxxxxx

01/17/2007 11:33 AM

Please respond to
Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>

To
Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>
cc
Subject
Re: [cross-project-issues-dev] Clarification on EE specification in        practice








I agree with John, and I would say that you need to say what is the minimum execution environment where your code can run, basically if you need to actually test your code against that environment.


For example TPTP model plugin will require at least EMF 2.2.2 which works on J2SE-1.4 (although is not specified in the manifest file) and we will also specify J2SE-1.4, that's why we won't prereq at least EMF 2.3.0 which require J2SE-1.5


The question that I still have is what happens when somebody tries to install Europa using a J2SE-1.4 environment, would the bundles that requires at least J2SE-1.5 be ignored, how would be handled a bundle that doesn't specify the required execution environment  (like EMF 2.2.2) or what happens if I run on J2SE 1.5 and I have both EMF 2.2.2 and EMF 2.3.0 which one will be proposed/picked (in my bundle I have specified EMF min=2.2.2 max=3.0.0)?


I've asked before if Europa will has a preferred (if not required) execution environment and I still don't know the answer, as I explained before the number of plugins (although there are still 603 bundles that don't have Bundle-RequiredExecutionEnvironment: specified, see my snapshot from http://wiki.eclipse.org/index.php/Image:Europa-manifest-files-20070115.zip) that will work only on J2SE-1.5 and those dependent on them seems to make J2SE-1.5 required in order to use Europa in a meaningful way.

Thanks !

Marius Slavescu
IBM Toronto Laboratory, Canada
Phone: 905-413-3610



John Arthorne/Ottawa/IBM@IBMCA
Sent by: cross-project-issues-dev-bounces@xxxxxxxxxxx

01/17/2007 10:22 AM

Please respond to
Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>


To
Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>
cc
Subject
Re: [cross-project-issues-dev] Clarification on EE specification in        practice










I think you should only ever specify the execution environment requirements for your own bundle.  Otherwise, you are unnecessarily exposing yourself to details of the prerequisite bundle that could change.  For a similar reason, you don't list the transitive prerequisites in the require-bundle header; it's just redundant information that can easily become stale and incorrect over time.  Let the OSGi resolver do its job - if your bundle relies on another bundle whose constraints aren't satisfied, then it will already mark your bundle as unresolved.  Perhaps I'm missing something, but I don't see any advantage to propagating the required execution environment to downstream bundles.


John

David M Williams <david_williams@xxxxxxxxxx>
Sent by: cross-project-issues-dev-bounces@xxxxxxxxxxx

16/01/2007 07:39 PM

Please respond to
Cross project issues <cross-project-issues-dev@xxxxxxxxxxx>


To
cross-project-issues-dev@xxxxxxxxxxx
cc
Subject
[cross-project-issues-dev] Clarification on EE specification in        practice












I just wanted a sanity check with other Europa projects. I first thought the answer to this was obvious.
Now I'm wondering if I could have been mistaken (as often is the case :)
or if it's ambiguous for others.

I've been assuming that if one of our bundles requires a bundle that requires J2SE 1.5 EE, then
we should also mark our bundle as requiring J2SE 1.5. (Even though, all by itelf, it doesn't).
That is, spec'ing what we really need to run correctly, taking pre-reqs into account.

Then, today, someone asked "why" ...  if the required bundle was 'optional', it wouldn't. But even if not optional,
at runtiime, things still won't run (for our bundle), and will simply be a longer chain of log messages (that one of it's
required bundles wasn't available ... and it woudl be logged as not available since a sufficient EE wasn't being used).
So in this case, we'd be spec'ing what our own specific code needed, not considering pre-reqs.

So ... just thought I'd ask ... anyone have a clear answer to this ... am I correct and "its obvious" or have I oversimplified.
I especially want to be sure we are consistent in Europa.

_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev
_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev
_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev

_______________________________________________
cross-project-issues-dev mailing list
cross-project-issues-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cross-project-issues-dev