[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [wtp-dev] Issue generating stub classes from WSDL

Hi Robert,

This mailing list is more for WTP developers. Questions about the usage of WTP can be posted to the newsgroup: http://www.eclipse.org/newsportal/thread.php?group=eclipse.webtools

I haven't run into this problem before, but it seems that you could be missing the wsdl4j jar. If you use the web services wizard to create your classes from a WSDL then all the required jars should be copied into your project and everything should work. There is a tutorial about creating axis2 web services on the wiki: http://wiki.eclipse.org/Creating_a_top-down_Axis2_Web_service

If that tutorial doesn't help we can continue this discussion on the newsgroup.

Mark Hutchinson, IBM Toronto Lab
Software Developer, Rational Java Web Services Tools
D3-341, 8200 Warden Avenue, Markham, Ontario, Canada
Phone: 905-413-3841 Email: mahutch@xxxxxxxxxx
Inactive hide details for "Robert Baldock" <robert.baldock@xxxxxxxxx>"Robert Baldock" <robert.baldock@xxxxxxxxx>


          "Robert Baldock" <robert.baldock@xxxxxxxxx>
          Sent by: wtp-dev-bounces@xxxxxxxxxxx

          09/23/2009 10:23 AM

          Please respond to
          "General discussion of project-wide or architectural issues." <wtp-dev@xxxxxxxxxxx>

To

<wtp-dev@xxxxxxxxxxx>

cc


Subject

[wtp-dev] Issue generating stub classes from WSDL

Hi –

This is my first post to the list and apologies for diving straight in with an issue but I’m having problems generating stub classes in Eclipse using the Axis2 WAR.

Specifically, I get this error:

Exception occurred while code generation for WSDL : java.lang.NoSuchMethodError: javax.wsdl.Operation.getExtensionAttributes()Ljava/util/Map;

Caused by: java.lang.NoSuchMethodError: javax.wsdl.Operation.getExtensionAttributes()Ljava/util/Map;
at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.populateOperations(WSDL11ToAxisServiceBuilder.java:1296)

I’m using Axis2 1.4.1 (though I get the same error with 1.5).

Has anyone seen this before and does anyone know how to resolve it?

Thanks.

Robert
_______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev

GIF image

GIF image

GIF image