[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [wtp-dev] Eclipse cannot find the tag library descriptors for JSFcore and html taglibs

Hi Behrang,

I forgot to say that this might be issue <https://glassfishplugins.dev.java.net/issues/show_bug.cgi?id=40> which is already fixed, but not yet in a released version. You can check to see if your project's build path is missing the relevant libraries.

Thanks,
Rochelle

raccah@xxxxxxxxxxxx wrote:
Behrang Saeedzadeh wrote:
Hi Kaloyan,

The wtp-dev mailing list is for collaboration between WTP developers.
You are encourage to use the designated newsgroup for user questions
like this:
http://www.eclipse.org/newsportal/thread.php?group=eclipse.webtools

Thanks for pointing to the user's mailing list :-) I have been trying to find it
for some time with no luck! Is there also a mailing list available for users?

Thanks, Kaloyan, for providing the links to the Glassfish plugins page and issuetracker.


Behrang, please file a bug there and we will investigate it.

And, there *is* a users mailing list for the glassfish plugins =): users@xxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Thanks,
Rochelle


As far as I understand the problem, the Glassfish server has the JSF
libs at runtime, but they are not included in the classpath of your Web
project targeted on the Glassfish runtime. The latter is responsibility
of the Glassfish server adapter that you have downloaded. It is not
develop in the WTP project and you should report the problem to the
Glassfish developers.

I also thought so and I have reported this to Arun Gupta. But I thought maybe this is a shortcoming in the server plugin API so I posted it both to Arun's blog and here.

Thanks,
Behrang

-----Original Message-----
From: wtp-dev-bounces@xxxxxxxxxxx [mailto:wtp-dev-bounces@xxxxxxxxxxx]
On Behalf Of Behrang
Sent: Friday, July 25, 2008 9:27 AM
To: wtp-dev@xxxxxxxxxxx
Subject: [wtp-dev] Eclipse cannot find the tag library descriptors for
JSFcore and html taglibs


Hi,

I have created a new Dynamic Web project in Ganymede, and I am deploying
to
Glassfish 2ur2.
I added Glassfish by clicking on "Download additional server adapters"
link
in the "New Server Runtime Environment" dialog.

I have used 2.5 as the Web module version and JavaServer Faces 1.2 as
the
configuration. For JSF libraries I have chosen Server Supplied JSF
implementation.

Then I create a new JSF/HTML page.

Now eclipse shows two errors next to:

<%@ taglib prefix="f"  uri="http://java.sun.com/jsf/core"%>
<%@ taglib prefix="h"  uri="http://java.sun.com/jsf/html"%>

saying that it cannot find the tlds for the core and html taglibs.
However
if I deploy my app it works fine, I think Eclipse does not know where
the
JSF libs are in Glassfish.

Any ideas how can I fix this?

Cheers,
Behrang
--
View this message in context:
http://www.nabble.com/Eclipse-cannot-find-the-tag-library-descriptors-fo
r-JSF-core-and-html-taglibs-tp18645764p18645764.html
Sent from the Eclipse WTP - general mailing list archive at Nabble.com.

_______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev
_______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev




_______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev