[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [wtp-dev] EMF 3.0 will require Java 5.0

Konstantin Komissarchik wrote:

I will throw something else out for this discussion... The current (1.4-level) EMF-generated classes that ship with WTP are rather difficult to use for those adopters who are using java 5.0. The reason is that as soon as you access this api Eclipse floods you with hundreds of warnings regarding generics safety that you cannot do anything about short of explicitly suppressing these warnings. The problem with suppressing is that you loose warnings unrelated to EMF-generated class that you _/do/_ want to see. The bottom line is that it would be very beneficial for adopters who are using java 5.0 if WTP EMF-generated classes were generated using the new EMF 3.0 generics capabilities.

Perhaps the JET templates could include @SuppressWarnings annotations, thus keeping the compiler at ease?

Regarding the “no 5.0 in common rule”, can we have an honest disclosure of where this requirement is coming from? What are the use cases? You can’t run WTP with just the common component. If there are certain adopters that need certain specific plugins to stay at 1.4 so that they can be re-used in non-WTP contexts, let’s enumerate those plugins instead of making a sweeping statement. If this is only a hypothetical requirement, let’s state that too so that everyone knows what we are dealing with.

Perhaps is worthwhile for these adopters to consider "retroweaving" the offending Java 5.0 plugins, to provide a retro-Eclipse to their customers. Options include "Retroweaver", "JBossRetro" and a few others.

I don't know if this technique could fit Eclipse, but JBoss ships certain products as 1.4 binaries compiled from 5.0 sources and retro'ed.