[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[wtp-dev] 50 plugins may need service level increased


I've checked, and on a recent build, we have roughly 50 plugins that may need to have their service field increased.
I've attached the list. And expect the plugin "owners" to react, only if needed.

I say "may need to have their service field increased", because some of these may really just have some insignificant
change that caused a new cvs version to be committed and released, but, may not have any bug fixes, per se.
And if that's so, that's fine, no need to increment service level (and, technically speaking, would be incorrect to do so).

But, if the plugin has had bug fixes from WTP 1.5.0, then the service field really should be incremented by '1' (and, infact, it should
have been incremented when the fixes were first released for a build).





What's it matter? Everything still works, right?
Well, it only still works if its installed all by itself from a zip or something.
The reason it its important for us to get right, is that adopters are supposed
to be able to specify, for example, that they really, really, want a minimum version of
a plugin, like 1.1.1, instead of 1.1.0. specifically to get some important bug fix, or users can
specify that they want to update to some specific service level, etc.
Through all the possibilities of update manager,
multiply installed components and products, etc., it would be possible, theoretically,
for 1.1.0 to already be installed, and all the automatic checking/loading etc., would think
"that's good enough  no need to insist 1.1.1 be present".

Now, in practice, I'm not sure there's huge risk of this sort of problem right now,
as this fine grained versioning stuff is sort of new,
so, I won't consider this a "blocking" problem, but ... please check the list ... and
if there's any doubt, I suggest incrementing the service field (third field) by 1.

Thanks,

Qualifier Versioning Increase
        org.eclipse.jst.common.annotations.controller
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608161031
Qualifier Versioning Increase
        org.eclipse.jst.common.annotations.core
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608170113
Qualifier Versioning Increase
        org.eclipse.jst.common.annotations.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.jst.common.frameworks
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.jst.common.project.facet.core
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608141517
Qualifier Versioning Increase
        org.eclipse.jst.ejb.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.jst.j2ee
                The current version was greater than the reference version.
                reference: 1.1.0.v200606222043   current: 1.1.0.v200609021535
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.core
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200609021535
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.ejb
                The current version was greater than the reference version.
                reference: 1.1.0.v200606152049   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.ejb.annotation.model
                The current version was greater than the reference version.
                reference: 1.1.0.v200606212143   current: 1.1.0.v200609051139
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.ejb.annotations.emitter
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200609051139
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.ejb.annotations.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606212143   current: 1.1.0.v200608291320
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.ejb.annotations.xdoclet
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608291320
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.jca
                The current version was greater than the reference version.
                reference: 1.1.0.v200606152049   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.jca.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608161031
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.navigator.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608252146
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.web
                The current version was greater than the reference version.
                reference: 1.1.0.v200606152049   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.webservice
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608292147
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.webservice.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.jst.j2ee.xdoclet.runtime
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608281049
Qualifier Versioning Increase
        org.eclipse.jst.server.generic.jboss
                The current version was greater than the reference version.
                reference: 1.5.0.v200606130315   current: 1.5.0.v200608281040
Qualifier Versioning Increase
        org.eclipse.jst.server.generic.ui
                The current version was greater than the reference version.
                reference: 1.0.100.v200606130315   current: 1.0.100.v200608221634
Qualifier Versioning Increase
        org.eclipse.jst.server.generic.weblogic
                The current version was greater than the reference version.
                reference: 1.5.0.v200606130315   current: 1.5.0.v200607241119
Qualifier Versioning Increase
        org.eclipse.jst.server.websphere.core
                The current version was greater than the reference version.
                reference: 1.0.100.v200606130315   current: 1.0.100.v200608251324
Qualifier Versioning Increase
        org.eclipse.jst.servlet.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130315   current: 1.1.0.v200608292147
Qualifier Versioning Increase
        org.eclipse.jst.ws.axis.creation.ui
                The current version was greater than the reference version.
                reference: 1.0.101.v200606130315   current: 1.0.101.v200608222020
Qualifier Versioning Increase
        org.eclipse.jst.ws.uddiregistry
                The current version was greater than the reference version.
                reference: 1.0.100.v200606130315   current: 1.0.100.v200608221651
Qualifier Versioning Increase
        org.eclipse.wst.common.emf
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130645   current: 1.1.0.v200608170113
Qualifier Versioning Increase
        org.eclipse.wst.common.emfworkbench.integration
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130645   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.wst.common.environment
                The current version was greater than the reference version.
                reference: 1.0.100.v200606130645   current: 1.0.100.v200608251934
Qualifier Versioning Increase
        org.eclipse.wst.common.frameworks
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130645   current: 1.1.0.v200608240040
Qualifier Versioning Increase
        org.eclipse.wst.common.frameworks.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130645   current: 1.1.0.v200608302330
Qualifier Versioning Increase
        org.eclipse.wst.common.snippets
                The current version was greater than the reference version.
                reference: 1.1.0.v200606141450   current: 1.1.0.v200608310300
Qualifier Versioning Increase
        org.eclipse.wst.common.ui.properties
                The current version was greater than the reference version.
                reference: 1.0.100.v200606130645   current: 1.0.100.v200608112028
Qualifier Versioning Increase
        org.eclipse.wst.css.core
                The current version was greater than the reference version.
                reference: 1.1.0.v200606141450   current: 1.1.0.v200608140437
Qualifier Versioning Increase
        org.eclipse.wst.css.ui
                The current version was greater than the reference version.
                reference: 1.0.100.v200606141450   current: 1.0.100.v200608140437
Qualifier Versioning Increase
        org.eclipse.wst.internet.proxy
                The current version was greater than the reference version.
                reference: 1.0.100.v200606130645   current: 1.0.100.v200608221651
Qualifier Versioning Increase
        org.eclipse.wst.javascript.core
                The current version was greater than the reference version.
                reference: 1.0.0.v200606141450   current: 1.0.0.v200608310300
Qualifier Versioning Increase
        org.eclipse.wst.javascript.ui
                The current version was greater than the reference version.
                reference: 1.0.0.v200606141450   current: 1.0.0.v200608310300
Qualifier Versioning Increase
        org.eclipse.wst.server.ui.doc.user
                The current version was greater than the reference version.
                reference: 1.0.2.v200605040131   current: 1.0.2.v200608302310
Qualifier Versioning Increase
        org.eclipse.wst.server.ui.infopop
                The current version was greater than the reference version.
                reference: 1.0.2.v200605040131   current: 1.0.2.v200608092232
Qualifier Versioning Increase
        org.eclipse.wst.validation
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130645   current: 1.1.0.v200608302330
Qualifier Versioning Increase
        org.eclipse.wst.validation.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606130645   current: 1.1.0.v200608161031
Qualifier Versioning Increase
        org.eclipse.wst.web
                The current version was greater than the reference version.
                reference: 1.1.0.v200606222043   current: 1.1.0.v200608302330
Qualifier Versioning Increase
        org.eclipse.wst.web.ui
                The current version was greater than the reference version.
                reference: 1.1.0.v200606161959   current: 1.1.0.v200608302056
Qualifier Versioning Increase
        org.eclipse.wst.webtools.doc.user
                The current version was greater than the reference version.
                reference: 1.0.201.v200605181650   current: 1.0.201.v200608302310
Qualifier Versioning Increase
        org.eclipse.wst.wsi
                The current version was greater than the reference version.
                reference: 1.0.101.v200606130645   current: 1.0.101.v200608301101