[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [wtp-dev] Request PMC approval for bug 135964

+1

 


From: wtp-dev-bounces@xxxxxxxxxxx [mailto:wtp-dev-bounces@xxxxxxxxxxx] On Behalf Of David M Williams
Sent: Monday, April 10, 2006 12:11 PM
To: wtp-dev@xxxxxxxxxxx
Subject: [wtp-dev] Request PMC approval for bug 135964

 


I just remembered I should follow my own rules!

Please see https://bugs.eclipse.org/bugs/show_bug.cgi?id=135964

I'd like to move up to the M6 based version of "base builder" to that we use to produce our 1.0.2 builds, and use it
to produce our final 1.0.2 build for release (well, we would use it for RC2 first).
This in no way effects the version of Java or other pre-reqs (still 1.4 and 3.1.2), it just changes the tools that are used to produced the
build.

As detailed in the bug, this fixes some problems with some scary spurious warnings we get in our builds
(16 "restricted access" warnings) -- which is good -- but
there is change in compiler versions we would use, so ... some might consider that too risky.
I do not think it is ... and do not want to live with those spurious warnings for all time .... but ... that's why we have a review process.

Please read the bug and cast a vote or veto ... or .. comment if you're not a PMC member :)

(Technically, I have already made the change for our warm up builds, but easy to revert if anyone feels this is too large a change to introduce now).