[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [wtp-dev] Hot Bug Status - RC4 Decision


Fabrizio,

Thx for reporting this problem and for your support of WTP. The criteria we are using at this point in time is to only fix serious bugs that are required by adopters who are about to ship a release on WTP 1.0. We are therefore deferring everything else to 1.0.1 or 1.5. The 1.0.1 stream should be very stable since we are also carefully controlling changes in it. Maven users should be able to pick up a 1.0.1 weekly build fairly soon.

Arthur Ryman,
IBM Software Group, Rational Division

blog: http://ryman.eclipsedevelopersjournal.com/
phone: +1-905-413-3077, TL 969-3077
assistant: +1-905-413-2411, TL 969-2411
fax: +1-905-413-4920, TL 969-4920
mobile: +1-416-939-5063, text: 4169395063@xxxxxxx



Fabrizio Giustina <fgiust@xxxxxxxxxx>
Sent by: wtp-dev-bounces@xxxxxxxxxxx

12/12/2005 11:57 AM

Please respond to
"General discussion of project-wide or architectural issues."

To
"General discussion of project-wide or architectural issues." <wtp-dev@xxxxxxxxxxx>
cc
wtp-pmc@xxxxxxxxxxx
Subject
Re: [wtp-dev] Hot Bug Status - RC4 Decision





Hi,
first of all sorry for hijacking this thread, I know that wtp 1.0 is
coming and you all are doing a wonderful job in fixing bugs and making
it stable...

however, according to the plans, WTP 1.0 will be shipped with a
serious regression from R7 which will prevent many existing web
projects from working correctly, and that will make it unusable
especially for maven users.

I'm talking about the deferred bugzilla #116783 (External JARs are
missing from deployed webapps,
https://bugs.eclipse.org/bugs/show_bug.cgi?id=116783 ).
Support for external libraries was working fine in R7 and lots of
users have started using it.
Many maven users now can automatically generate WTP configurations
thanks to the maven eclipse plugin, with wtp support. However, any
migrated project which uses at least one jar (100%) will not work
anymore in WTP 1.0. While support for generating wtp 1.0 descriptors
is also nearly ready for the maven plugin, that would be totally
useless too if external libraries will not work.

So, also if late, I just would like to ask you if there is any chance
that a fix for #116783 could find its way to 1.0. The bug was
initially in the hot list, scheduled for rc2, and then deferred to
1.0.1 since it requires, according to Tim, a significant change. Its
gravity, however, could maybe justify it?

sorry for pushing this to the mailing list and thanks for all your
work, I am just looking forward to start using WTP 1.0
fabrizio


On 12/12/05, Timothy Deboer <deboer@xxxxxxxxxx> wrote:
>
> Hi Arthur,
>
> Please see my post to the mailing list on Saturday night. 120109 is blocking the dynamic install of the Geronimo server adapter and we only need to change a URL to fix it. There is also another defect in the note that was deferred to 1.0.1 but I think we need to reconsider.
>
> Thanks,
> Tim deBoer
>  WebSphere Tools - IBM Canada Ltd.
>  (905) 413-3503  (tieline 969)
>  deboer@xxxxxxxxxx
_______________________________________________
wtp-dev mailing list
wtp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/wtp-dev