[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [wsvt-dev] Ant WARNING no WS-I Compliance validator



Hi Chad,

Please open a defect against the WSVT -> WSDL Validator for the problems
you are having with the XML catalog. You can open a defect at
https://bugs.eclipse.org/bugs/.

You can ignore that warning. It will disappear with our next build. The
WSVT tools were tightly coupled in the build you are using where the WSDL
validator required a WS-I validator but the WS-I validator was unable to
run in Ant. The tight coupling has been fixed in CVS but we still need to
get the WS-I test tools working.

Thanks,

Lawrence



                                                                           
             Chad.Iverson@well                                             
             sfargo.com                                                    
             Sent by:                                                   To 
             wsvt-dev-admin@ec         wsvt-dev@xxxxxxxxxxx                
             lipse.org                                                  cc 
                                                                           
                                                                   Subject 
             06/08/2004 11:28          [wsvt-dev] Ant WARNING no WS-I      
             AM                        Compliance validator                
                                                                           
                                                                           
             Please respond to                                             
                 wsvt-dev                                                  
                                                                           
                                                                           




Hi,

I am running version 1.1.1 of WSVT.  I am using JDK 1.3.1 I have also tried
with 1.4 with the same results.

The validator works fine in Eclipse, but I can't get it to work in Ant.  I
have tried everything and I am stuck can someone give me a hint please.

I followed the examples on the man Ant page, when I don't use the
xmlcatalog
(like the How to in the FAQ) I get java.lang.NoSuchMethodError when it
tries
to addCatalog.  When I use the xmlcatalog I get this:

Buildfile: build.xml

WSDLValidate:
[wsdlvalidate] ---------------------------------------
[wsdlvalidate] Validating StockQuoteService.wsdl - VALID
[wsdlvalidate] ---------------------------------------
[wsdlvalidate] WARNING 1:1:There is no WS-I Compliance validator registered
for namespace http://schemas.xmlsoap.org/wsdl/.

Thanks in advance,
Chad
_______________________________________________
wsvt-dev mailing list
wsvt-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/wsvt-dev