[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[virgo-dev] Should updated dependency bundle symbolic names be treated as a backward incompatibility?

I notice that the recent Gemini Web 2.2.0.M02 milestone changed several bundle symbolic names of dependencies. I'm wondering if this should count as a backward incompatibility (for Gemini Web and Virgo) and require us to rev the major version number to conform to semantic versioning.

I notice that the same happened in Virgo 3.5.0 and we didn't bump the version to 4.0.

Perhaps it's a reasonable working assumption that the majority of users will generate manifests using bundlor or bnd and therefore not be dependent on such bundle symbolic names.