[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[virgo-dev] update-dependency.rb question

Dmitry,
Sorry this took a long time to look at.  We don't need "require 'fileutils'" in the source because fileutils.rb is part of ruby/core and ought to be built-in.

If it doesn't work for you I suggest you check the ruby installation you are using. There might be a RUBYLIBs env variable which is over-riding the core??? I, too, am not ruby-literate to this level.

I'm currently running with the same version of ruby you are using, on a mac, but a later patchlevel...

13:55:49 : ruby --version
ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-darwin10]

If anyone else is seeing this, we might update the source code, but we shouldn't have to.

Having said that I can't find any doc online which explicitly says this, and most examples include the line "require 'fileutils'" so I suppose we ought to update the file.  Thanks for the feedback.

Regards,
Steve Powell
[W:+44-2380-111-528; M: +44-7815-838-558; H:+44-1962-775-598]
Links: SpringSource<http://www.springsource.org/> (a division of VMware<http://www.vmware.com/>),

Virgo (Website<http://www.eclipse.org/virgo>, Wiki<http://wiki.eclipse.org/Virgo> and Forum<http://www.eclipse.org/forums/index.php?t=thread&frm_id=159>)

----------definitions from the SPD----------
Cannelloni n. A narrow boat for one.
Verisimilitude adj. Extremely evenly masticated.
Decrepit v. To muck-out Royal stables.

Message: 3
Date: Thu, 12 Aug 2010 10:03:53 -0400
From: Dmitry Sklyut <dmitry@xxxxxxxxxxx<mailto:dmitry@xxxxxxxxxxx>>
Subject: [virgo-dev] update-dependency.rb question
To: Virgo Project <virgo-dev@xxxxxxxxxxx<mailto:virgo-dev@xxxxxxxxxxx>>
Message-ID:
<AANLkTimSFOcWU-HODChoUs88jDd15cT-N+j2zGb_in4c@xxxxxxxxxxxxxx<mailto:AANLkTimSFOcWU-HODChoUs88jDd15cT-N+j2zGb_in4c@xxxxxxxxxxxxxx>>
Content-Type: text/plain; charset="iso-8859-1"

Hi,

I needed to bring snaps up to date and noticed that update-dependency.rb
kept on failing for me.

../org.eclipse.virgo.web-server/scripts/update-dependency.rb:29:
uninitialized constant FileUtils (NameError)

OSX
ruby --version
ruby 1.8.7 (2009-06-12 patchlevel 174) [universal-darwin10.0]

Boiled it down to missing:
require 'fileutils'

in update-dependency.rb

Adding that in, solved the problem for me, but I wonder if anyone is having
same issues or it is just my set-up.  I am noob in ruby.


Regards,

Dmitry