[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] [Re: [Re: Tycho and bundle name]]

I don't think this is a version number issue... The "0.0.1-SNAPSHOT" in my pom refers to the parent POM's version (created for Tycho), not the plugin's version. The plugin's version is never used in my example (specified nowhere in the POMs).

I tried a lot of modifications but Tycho keeps displaying me "null" for symbolic name... Where the hell does it look for this name??

> Message du 11/07/12 16:49
> de : "SimonGoodall"<simon.goodall@xxxxxxxxxxxxxxx>
> Ã : "Paul-Emmanuel"<src182@xxxxxxxxx>;"Tychouserlist"<tycho-user@xxxxxxxxxxx>
> cc : 
> objet : Re: [tycho-user] [Re: Tycho and bundle name]
> 
> Hi,
> 
> The artifactId and bundle symbolic name should match. Your version
> number should also match (with -SNAPSHOT in the pom and .qualifier in
> the MANIFEST.MF)  - looks like it should be 0.0.1.qualifier rather
> than 1.0.0 in your case.
> 
> Regards,
> 
> Simon
> 
> On 11 July 2012 15:45, Paul-Emmanuel <src182@xxxxxxxxx> wrote:
> > Sorry but I don't get it... What has to match between the POM and the
> > manifest?
> >
> > I tried :
> >
> > In the POM :
> >
> > <project>
> >
> > <modelVersion>4.0.0</modelVersion>
> >
> > <parent>
> >
> > ...
> >
> > </parent>
> >
> > <groupId>com.my.builder</groupId>
> >
> > <artifactId>MyBuilder</artifactId>
> >
> > <packaging>eclipse-plugin</packaging>
> >
> > </project>
> >
> > And in the MANIFEST :
> >
> > Manifest-Version: 1.0
> >
> > Bundle-ManifestVersion: 2
> >
> > Bundle-Name: MyBuilder
> >
> > Bundle-SymbolicName: com.my.builder;singleton:=true
> >
> > Bundle-Version: 1.0.0
> >
> > Bundle-Activator:
> >
> > But I always have the same error. Why does it indicate a "null" symbolic
> > name?
> >
> > Thank you
> >
> >> Message du 11/07/12 16:25
> >> de : "JosephDCarrollJr"
> >> Ã : "Paul-Emmanuel";"Tychouserlist"
> >> cc :
> >> objet : Re: [tycho-user] Tycho and bundle name
> >
> >>
> >> Take a look at this tutorial:
> >> http://www.vogella.com/articles/EclipseRCP/article.html
> >>
> >>
> >> Your problem is in the manifest, the bundle name displayed in the Eclipse
> >> IDE is not the same as the symbolic-name (ie. the name used at build/run
> >> time).
> >>
> >>
> >> JD
> >>
> >>
> >> On Wed, Jul 11, 2012 at 8:49 AM, Paul-Emmanuel <src182@xxxxxxxxx> wrote:
> >>
> >>
> >> >
> >>
> >> > Hello,
> >>
> >> >
> >>
> >> >
> >>
> >> > I recently tried to build my Eclipse plugins with Tycho, following the
> >> > Vogella's tutorial
> >> > (http://www.vogella.com/articles/EclipseTycho/article.html) and here is the
> >> > error raised :
> >>
> >> >
> >>
> >> >
> >>
> >> > [ERROR] Failed to execute goal
> >> > org.eclipse.tycho:tycho-packaging-plugin:0.15.0:v
> >> > alidate-id (default-validate-id) on project builder
> >> > : The Maven artifactId (currently: "builder") must
> >> > be the same as the bundle symbolic name (currently: "null") -> [Help 1]
> >>
> >> >
> >>
> >> >
> >>
> >> > And my project files are :
> >>
> >> >
> >>
> >> >
> >>
> >> > for the "parent" POM : exactly as in vogella tutorial, with modules path
> >> > customized
> >>
> >> >
> >>
> >> > for the "builder" project POM :
> >>
> >> > <project>
> >>
> >> > <modelVersion>4.0.0</modelVersion>
> >>
> >> > <parent>
> >>
> >> > <relativePath>../master/pom.xml</relativePath>
> >>
> >> > <groupId>perso</groupId>
> >>
> >> > <artifactId>master</artifactId>
> >>
> >> > <version>0.0.1-SNAPSHOT</version>
> >>
> >> > </parent>
> >>
> >> > <artifactId>builder</artifactId>
> >>
> >> > <packaging>eclipse-plugin</packaging>
> >>
> >> > </project>
> >>
> >> >
> >>
> >> >
> >>
> >> > The manifest file of my plugin is :
> >>
> >> > ...
> >>
> >> > Manifest-Version: 1.0
> >>
> >> > Bundle-ManifestVersion: 2
> >>
> >> > Bundle-Name: Builder
> >>
> >> > Bundle-SymbolicName: builder;singleton:=true
> >>
> >> > ...
> >>
> >> >
> >>
> >> > So, does anyone have an idea of the error's source?
> >>
> >> >
> >>
> >> > Thanks
> >>
> >> >
> >>
> >>
> >> > _______________________________________________
> >> > tycho-user mailing list
> >> > tycho-user@xxxxxxxxxxx
> >> > https://dev.eclipse.org/mailman/listinfo/tycho-user
> >> >
> >> >
> >
> >
> >>
> >
> > _______________________________________________
> > tycho-user mailing list
> > tycho-user@xxxxxxxxxxx
> > https://dev.eclipse.org/mailman/listinfo/tycho-user
> >
>