[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] No match found for native code

Can you provide a small standalone example project we can use to
reproduce the problem?

--
Regards,
Igor

On 12-07-06 3:40 PM, Joey Mink wrote:
Hi all,

I'm using Tycho to build an Eclipse plug-in whose MANIFEST.MF contains a
Bundle-NativeCode header[1].  When I `mvn install`, I get this error
message[2]. The native code files are in the root of the plug-in
project, and all seems to work well when I launch the plug-ins in an
Eclipse application from the PDE.  I've attached my effective pom.xml[3]
(my apologies for the length).  Any thoughts on this "No match found for
native code" error?

Thanks!
Joey

[1]
Bundle-NativeCode: libgluegen-rt.so; osname=linux; processor=amd64,
  gluegen-rt.dll; osname=windows; processor=x86,
  libgluegen-rt.jnilib; osname=macosx; processor=x86_64

[2]
[WARNING] No sustem.bundle
[ERROR] Internal error: java.lang.RuntimeException:
org.osgi.framework.BundleException: Bundle
com.exoanalytic.gov.nasa.worldwind.glugen-rt cannot be resolved
[ERROR] Resolution errors:
[ERROR] Bundle com.exoanalytic.gov.nasa.worldwind.glugen-rt - No match
found for native code: libgluegen-rt.so; processor=amd64; osname=linux,
gluegen-rt.dll; processor=x86; osname=windows, libgluegen-rt.jnilib;
processor=x86_64; osname=macosx

[3]
<?xml version="1.0" encoding="UTF-8"?>
<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd";
xmlns="http://maven.apache.org/POM/4.0.0";
     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";>
   <modelVersion>4.0.0</modelVersion>
   <parent>
     <artifactId>com.exoanalytic.gov.nasa.worldwind.mavenparent</artifactId>
     <groupId>com.exoanalytic</groupId>
     <version>1.3.0-SNAPSHOT</version>
     <relativePath>../gov.nasa.worldwind.mavenparent</relativePath>
   </parent>
   <groupId>com.exoanalytic</groupId>
   <artifactId>com.exoanalytic.gov.nasa.worldwind.glugen-rt</artifactId>
   <version>1.3.0-SNAPSHOT</version>
   <packaging>eclipse-plugin</packaging>
   <properties>
     <tycho-version>0.14.1</tycho-version>
   </properties>
   <repositories>
     <repository>
       <id>indigo</id>
       <url>http://download.eclipse.org/releases/indigo</url>
       <layout>p2</layout>
     </repository>
     <repository>
       <snapshots>
         <enabled>false</enabled>
       </snapshots>
       <id>central</id>
       <name>Maven Repository Switchboard</name>
       <url>http://repo1.maven.org/maven2</url>
     </repository>
   </repositories>
   <pluginRepositories>
     <pluginRepository>
       <releases>
         <updatePolicy>never</updatePolicy>
       </releases>
       <snapshots>
         <enabled>false</enabled>
       </snapshots>
       <id>central</id>
       <name>Maven Plugin Repository</name>
       <url>http://repo1.maven.org/maven2</url>
     </pluginRepository>
   </pluginRepositories>
   <build>

<sourceDirectory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/src/main/java</sourceDirectory>

<scriptSourceDirectory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/src/main/scripts</scriptSourceDirectory>

<testSourceDirectory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/src/test/java</testSourceDirectory>

<outputDirectory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/target/classes</outputDirectory>

<testOutputDirectory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/target/test-classes</testOutputDirectory>
     <resources>
       <resource>

<directory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/src/main/resources</directory>
       </resource>
     </resources>
     <testResources>
       <testResource>

<directory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/src/test/resources</directory>
       </testResource>
     </testResources>

<directory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/target</directory>

<finalName>com.exoanalytic.gov.nasa.worldwind.glugen-rt-1.3.0-SNAPSHOT</finalName>
     <pluginManagement>
       <plugins>
         <plugin>
           <artifactId>maven-antrun-plugin</artifactId>
           <version>1.3</version>
         </plugin>
         <plugin>
           <artifactId>maven-assembly-plugin</artifactId>
           <version>2.2-beta-5</version>
         </plugin>
         <plugin>
           <artifactId>maven-dependency-plugin</artifactId>
           <version>2.1</version>
         </plugin>
         <plugin>
           <artifactId>maven-release-plugin</artifactId>
           <version>2.0</version>
         </plugin>
         <plugin>
           <groupId>org.eclipse.tycho</groupId>
           <artifactId>tycho-surefire-plugin</artifactId>
           <version>0.14.1</version>
         </plugin>
         <plugin>
           <artifactId>maven-surefire-plugin</artifactId>
           <version>2.12</version>
         </plugin>
       </plugins>
     </pluginManagement>
     <plugins>
       <plugin>
         <groupId>org.eclipse.tycho</groupId>
         <artifactId>tycho-maven-plugin</artifactId>
         <version>0.14.1</version>
         <extensions>true</extensions>
       </plugin>
       <plugin>
         <groupId>org.eclipse.tycho</groupId>
         <artifactId>target-platform-configuration</artifactId>
         <version>0.14.1</version>
         <configuration>
           <environments>
             <environment>
               <os>linux</os>
               <ws>gtk</ws>
               <arch>x86</arch>
             </environment>
             <environment>
               <os>linux</os>
               <ws>gtk</ws>
               <arch>x86_64</arch>
             </environment>
             <environment>
               <os>win32</os>
               <ws>win32</ws>
               <arch>x86</arch>
             </environment>
             <environment>
               <os>win32</os>
               <ws>win32</ws>
               <arch>x86_64</arch>
             </environment>
             <environment>
               <os>macosx</os>
               <ws>cocoa</ws>
               <arch>x86_64</arch>
             </environment>
           </environments>
         </configuration>
       </plugin>
       <plugin>
         <artifactId>maven-clean-plugin</artifactId>
         <version>2.4.1</version>
         <executions>
           <execution>
             <id>default-clean</id>
             <phase>clean</phase>
             <goals>
               <goal>clean</goal>
             </goals>
           </execution>
         </executions>
       </plugin>
       <plugin>
         <artifactId>maven-install-plugin</artifactId>
         <version>2.3.1</version>
         <executions>
           <execution>
             <id>default-install</id>
             <phase>install</phase>
             <goals>
               <goal>install</goal>
             </goals>
           </execution>
         </executions>
       </plugin>
       <plugin>
         <groupId>org.eclipse.tycho</groupId>
         <artifactId>tycho-p2-plugin</artifactId>
         <version>0.14.1</version>
         <executions>
           <execution>
             <id>default-update-local-index</id>
             <phase>install</phase>
             <goals>
               <goal>update-local-index</goal>
             </goals>
           </execution>
           <execution>
             <id>default-p2-metadata</id>
             <phase>package</phase>
             <goals>
               <goal>p2-metadata</goal>
             </goals>
           </execution>
         </executions>
       </plugin>
       <plugin>
         <artifactId>maven-resources-plugin</artifactId>
         <version>2.4.3</version>
         <executions>
           <execution>
             <id>default-resources</id>
             <phase>process-resources</phase>
             <goals>
               <goal>resources</goal>
             </goals>
           </execution>
           <execution>
             <id>default-testResources</id>
             <phase>process-test-resources</phase>
             <goals>
               <goal>testResources</goal>
             </goals>
           </execution>
         </executions>
       </plugin>
       <plugin>
         <groupId>org.eclipse.tycho</groupId>
         <artifactId>tycho-compiler-plugin</artifactId>
         <version>0.14.1</version>
         <executions>
           <execution>
             <id>default-compile</id>
             <phase>compile</phase>
             <goals>
               <goal>compile</goal>
             </goals>
           </execution>
         </executions>
       </plugin>
       <plugin>
         <groupId>org.eclipse.tycho</groupId>
         <artifactId>tycho-packaging-plugin</artifactId>
         <version>0.14.1</version>
         <executions>
           <execution>
             <id>default-package-plugin</id>
             <phase>package</phase>
             <goals>
               <goal>package-plugin</goal>
             </goals>
           </execution>
           <execution>
             <id>default-build-qualifier</id>
             <phase>validate</phase>
             <goals>
               <goal>build-qualifier</goal>
             </goals>
           </execution>
           <execution>
             <id>default-validate-id</id>
             <phase>validate</phase>
             <goals>
               <goal>validate-id</goal>
             </goals>
           </execution>
           <execution>
             <id>default-validate-version</id>
             <phase>validate</phase>
             <goals>
               <goal>validate-version</goal>
             </goals>
           </execution>
         </executions>
       </plugin>
       <plugin>
         <artifactId>maven-deploy-plugin</artifactId>
         <version>2.5</version>
         <executions>
           <execution>
             <id>default-deploy</id>
             <phase>deploy</phase>
             <goals>
               <goal>deploy</goal>
             </goals>
           </execution>
         </executions>
       </plugin>
       <plugin>
         <artifactId>maven-site-plugin</artifactId>
         <version>2.0.1</version>
         <executions>
           <execution>
             <id>default-site</id>
             <phase>site</phase>
             <goals>
               <goal>site</goal>
             </goals>
             <configuration>

<outputDirectory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/target/site</outputDirectory>
               <reportPlugins>
                 <reportPlugin>
                   <groupId>org.apache.maven.plugins</groupId>

<artifactId>maven-project-info-reports-plugin</artifactId>
                 </reportPlugin>
               </reportPlugins>
             </configuration>
           </execution>
           <execution>
             <id>default-deploy</id>
             <phase>site-deploy</phase>
             <goals>
               <goal>deploy</goal>
             </goals>
             <configuration>

<outputDirectory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/target/site</outputDirectory>
               <reportPlugins>
                 <reportPlugin>
                   <groupId>org.apache.maven.plugins</groupId>

<artifactId>maven-project-info-reports-plugin</artifactId>
                 </reportPlugin>
               </reportPlugins>
             </configuration>
           </execution>
         </executions>
         <configuration>

<outputDirectory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/target/site</outputDirectory>
           <reportPlugins>
             <reportPlugin>
               <groupId>org.apache.maven.plugins</groupId>
               <artifactId>maven-project-info-reports-plugin</artifactId>
             </reportPlugin>
           </reportPlugins>
         </configuration>
       </plugin>
     </plugins>
   </build>
   <reporting>

<outputDirectory>/Users/walk_n_wind/dev/ide/gov.nasa.worldwind.glugen-rt/target/site</outputDirectory>
   </reporting>
</project>



_______________________________________________
tycho-user mailing list
tycho-user@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-user