[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-user] Building tycho with the same bootstrap version

It has to be a different, previously built version.

Out of curiously, how do you plan to distribute Tycho with Fedora? Does
Fedora have maven2 repo?

--
Regards,
Igor



On 12-05-31 12:02 PM, Roland Grunberg wrote:
If I attempt to build Tycho (eg. 0.14.1) by specifying the exact same
version of it for the bootstrapping, the build will give a cyclic
dependency error :

[ERROR] The projects in the reactor contain a cyclic reference: Edge
between
'Vertex{label='org.eclipse.tycho:tycho-compiler-plugin'}' and
'Vertex{label='org.eclipse.tycho:tycho-core'}' introduces to cycle in the
graph org.eclipse.tycho:tycho-core -->  org.eclipse.tycho:tycho-embedder-api
-->  org.eclipse.tycho:org.eclipse.tycho.embedder.shared -->
org.eclipse.tycho:tycho-compiler-plugin -->  org.eclipse.tycho:tycho-core ->
[Help 1]

I could make a bogus version, build it, and change the version back to what
it should be and build again. Is there any way to keep the versions the
same, and build just once (assuming the same version is in the m2 cache) ?

I know that this is probably more of a Maven issue, but I ask because in
uilding Tycho for Fedora it wouldn't be acceptable to include a pre-built
version (0.13.0) to resolve against. We build by resolving against the
previously built version. This works as long as the versions are different,
but if they're the same and we're just making a minor change we'd basically
have to build twice.

Cheers,