[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-dev] Compile error in ExpandedProduct when moving to recent p2

Hi Pascal,

I've already done the change that adapts Tycho to the p2 changes: https://git.eclipse.org/r/#/c/41895/
In fact, being able to do that change was the reason why I submitted the changes in p2.

Before submitting the change, I still need to add some unit tests to it. Also, I didn't want to submit it too long before M6 so that we don't have to update Tycho's target definition file all the time. This wouldn't be an issue if the Eclipse platform retained I-builds until the next milestone build, but unfortunately they don't.

Best regards
Tobias


> -----Original Message-----
> From: tycho-dev-bounces@xxxxxxxxxxx [mailto:tycho-dev-
> bounces@xxxxxxxxxxx] On Behalf Of Pascal Rapicault
> Sent: Dienstag, 3. März 2015 15:49
> To: Tycho developers list
> Subject: [tycho-dev] Compile error in ExpandedProduct when moving to
> recent p2
> 
> When I build Tycho against p2 from master, I get compile errors because
> the class ExpandedProduct is missing some methods. These errors occur
> because the IProductDescriptor class in p2 has been modified
> (http://git.eclipse.org/c/equinox/rt.equinox.p2.git/commit/?id=c3cdccddfd
> 6fb7b164b216b605252b718004f6c3).
> 
> Though these errors are not new , I'm wondering what are the plans to
> address those and if a patch is needed (which I can provide).
> 
> Pascal
> _______________________________________________
> tycho-dev mailing list
> tycho-dev@xxxxxxxxxxx
> To change your delivery options, retrieve your password, or unsubscribe
> from this list, visit
> https://dev.eclipse.org/mailman/listinfo/tycho-dev