[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-dev] Tycho enforcer rules plugin

Hi,

I created this bug in JIRA https://jira.codehaus.org/browse/MENFORCER-222

Regards,
Benoit Maggi

-----Message d'origine-----
De : tycho-dev-bounces@xxxxxxxxxxx [mailto:tycho-dev-bounces@xxxxxxxxxxx] De la part de Karl Heinz Marbaise
Envoyé : mercredi 4 février 2015 18:06
À : tycho-dev@xxxxxxxxxxx
Objet : Re: [tycho-dev] Tycho enforcer rules plugin

Hi,

Can you please create a jira for this problem....and please with an example project to recreate the problem...

So we can make probably a fix for it


Kind regards
Karl Heinz Marbaise


On 2/4/15 5:59 PM, MAGGI Benoit wrote:
> Hi,
>
> Note that something is probably wrong in the latest version 1.4
>
> ðrequireSameVersions doesn't seems to work
>
> ðI use 1.3
>
> I had a quick look  :
>
> -Tycho add *p2.eclipse-plugin:*to each dependency (at least from what 
> I understand with a mvn dependency:tree)
>
> -The enforcer plugin presume that dependency follow this pattern : *// 
> pattern is groupId[:artifactId[:type[:classifier]]] *
>
> (Check L107 here :

> > http://svn.apache.org/viewvc/maven/enforcer/tags/1.4/enforcer-rules/
> > src/main/java/org/apache/maven/plugins/enforcer/RequireSameVersions.
> > java?view=markup)
> (Same code in 1.3 :
> http://svn.apache.org/viewvc/maven/enforcer/tags/enforcer-1.3/enforcer
> -rules/src/main/java/org/apache/maven/plugins/enforcer/RequireSameVers
> ions.java?view=markup)
>
> I believe that this rule will never work with tycho-plugin-eclipse.
>
> Did I missed something ?
>
> I think I have to code my own rule which will be specific to eclipse-plugin.
>
> Regards,
>
> Benoit Maggi
>
> *De :*tycho-dev-bounces@xxxxxxxxxxx
> [mailto:tycho-dev-bounces@xxxxxxxxxxx] *De la part de* Jeff MAURY 
> *Envoyé :* mercredi 4 février 2015 15:31 *À :* Tycho developers list 
> *Objet :* Re: [tycho-dev] Tycho enforcer rules plugin
>
> Assumed that Tycho represents OSGI dependencies as Maven dependencies, 
> can't you use a Maven Enforcer plugin provided rule ?
>
> Regards
>
> Jeff
>
> On Wed, Feb 4, 2015 at 2:00 PM, MAGGI Benoit <Benoit.MAGGI@xxxxxx 
> <mailto:Benoit.MAGGI@xxxxxx>> wrote:
>
> Hi Tycho team,
>
> I am looking for a Tycho plugin for enforcing some validation rules.
>
> My need is to enforce the same version number for internal 
> dependencies (in the same project)
>
> I am looking for the Tycho version of this plugin :
> http://maven.apache.org/enforcer/enforcer-rules/
>
> I found this plugin (not in Tycho git repositories):
>
> http://search.maven.org/#search%7Cgav%7C1%7Cg%3A%22org.sonatype.tycho%
> 22%20AND%20a%3A%22tycho-enforcer-rules%22
>
> My questions :
>
> -Is there a way to enforce these type of rules with a Tycho plugin ?
>
> -Why the Sonatype plugin was not integrate in the first contribution 
> to eclipse-tycho ?
>
> See *https://eclipse.org/proposals/tycho/**: *The initial code based 
> will be contributed by Sonatype, and is currently located at Github:
> *http://github.com/sonatype/sonatype-tycho*.
>
> -Is there any work in progress on the subject ?
>
> Regards,
>
> Benoit Maggi
>
>
> _______________________________________________
> tycho-dev mailing list
> tycho-dev@xxxxxxxxxxx <mailto:tycho-dev@xxxxxxxxxxx> To change your 
> delivery options, retrieve your password, or unsubscribe from this 
> list, visit https://dev.eclipse.org/mailman/listinfo/tycho-dev
>
>
>
> --
>
> Jeff MAURY
>
>
> "Legacy code" often differs from its suggested alternative by actually 
> working and scaling.
>   - Bjarne Stroustrup
>
> http://www.jeffmaury.com
> http://riadiscuss.jeffmaury.com
> http://www.twitter.com/jeffmaury
>
_______________________________________________
tycho-dev mailing list
tycho-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit https://dev.eclipse.org/mailman/listinfo/tycho-dev