[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tycho-dev] Running junit plugin tests with tycho

I don't recall ever needing to do this, but you can specify something
like [3.8,4.0) in your test project bundle manifest to force dependency
on junit 3.x and this in turn will make Tycho use junit3 test launcher.

--
Regards,
Igor


On 12-03-23 6:16 PM, Anna Dushistova wrote:
After enabling debug output,
I am seeing "[DEBUG] Using test framework org.junit4".
Our tests are junit3 based though. Do I need to specify junit version
explicitly?

Anna.

On Wed, Feb 15, 2012 at 2:34 AM, Igor Fedorenko<ifedorenko@xxxxxxxxxxxx> wrote:
I don't know why Tycho can't find any tests in your project. Have a look
at tycho demo application [1], it shows the basic test project setup.
Maybe you can see any differences.

[1]
http://git.eclipse.org/c/tycho/org.eclipse.tycho.git/tree/tycho-demo/itp01/tycho.demo.itp01.tests?id=tycho-0.14.0

--
Regards,
Igor


On 12-02-14 5:11 PM, Anna Dushistova wrote:

Hi All,

Is there any special setup needed for running junit plugin tests
during the build?
I have surefire included to my parent pom.xml and the
org.eclipse.rse.tests's pom.xml
but it doesn't seem to be able to find them.
Here is the console output:
https://hudson.eclipse.org/hudson/job/tm-master-nightly/26/console

Any help will be appreciated.
Thanks!
Anna.
_______________________________________________
tycho-dev mailing list
tycho-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-dev

_______________________________________________ tycho-dev mailing list tycho-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/tycho-dev
_______________________________________________
tycho-dev mailing list
tycho-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/tycho-dev