[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [tcf-dev] TCF repository doesn't seem to be working all of a sudden

Hi,

+1 to what Eugene said. Using "http://download.eclipse.org/tools/tcf/builds/1.0/milestones"; is preferable, but we should have a symbolic link to keep the old repository location valid.

Martin, can you make the necessary changes on the server? I can take care of the delivery location on your mark.

And can you have a look at the "tcf-master" build problems too?

...
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.7:run (deploy) on project org.eclipse.tcf.repo: An Ant BuildException has occured: Unable to delete file /home/data/httpd/download.eclipse.org/tools/tcf/builds/development/nightly/META-INF/ECLIPSE_.RSA
...

Thanks, Uwe :)


> -----Original Message-----
> From: tcf-dev-bounces@xxxxxxxxxxx [mailto:tcf-dev-bounces@xxxxxxxxxxx] On Behalf Of Tarassov,
> Eugene
> Sent: Donnerstag, 31. Mai 2012 20:12
> To: TCF Development
> Subject: Re: [tcf-dev] TCF repository doesn't seem to be working all of a sudden
> 
> Hi Martin,
> 
> > I would prefer using repos by their version numbers
> 
> I agree, but I'm concerned that repository names are public, and changing them will upset everybody
> who use them in Eclipse, build scripts, etc.
> We have to handle this same way as a public API. At least, we might need to keep old names as
> symbolic links or something.
> 
> Regards,
> Eugene
> 
> -----Original Message-----
> From: tcf-dev-bounces@xxxxxxxxxxx [mailto:tcf-dev-bounces@xxxxxxxxxxx] On Behalf Of Oberhuber,
> Martin
> Sent: Thursday, May 31, 2012 1:19 AM
> To: TCF Development
> Subject: Re: [tcf-dev] TCF repository doesn't seem to be working all of a sudden
> 
> The problem was that .../juno/... was double booked by tcf-1.0 and tcf-1.1 (aka master).
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=381001
> 
> Since I had no direct access to the Hudson jobs, I moved away the .../juno/... location into .../1.0/... for
> the release train contribution, such that it's not overwritten accidentally.
> Now Eugene fixed the master job on Hudson, so I moved it back. Just verified - we now have following
> repos:
> 
> http://download.eclipse.org/tools/tcf/builds/0.4/nightly
> 
> http://download.eclipse.org/tools/tcf/builds/juno/milestones
> http://download.eclipse.org/tools/tcf/builds/juno/nightly
> 
> http://download.eclipse.org/tools/tcf/builds/development/nightly
> 
> Personally, since tcf-1.0 is designed to run on either Juno or Indigo and because we might want to
> release
> tcf-1.1 well before the Kepler stream is out, I would prefer using repos by their version numbers:
>     http://download.eclipse.org/tools/tcf/builds/1.0/milestones
> which is an exact copy of ../juno/... right now.
> 
> What do others think ?
> 
> Martin
> 
> 
> -----Original Message-----
> From: tcf-dev-bounces@xxxxxxxxxxx [mailto:tcf-dev-bounces@xxxxxxxxxxx] On Behalf Of Tarassov,
> Eugene
> Sent: Wednesday, May 30, 2012 11:03 PM
> To: TCF Development
> Subject: Re: [tcf-dev] TCF repository doesn't seem to be working all of a sudden
> 
> The nightly build is at /tools/tcf/..., not at /tcf/...:
> http://download.eclipse.org/tools/tcf/builds/juno/nightly
> It seems to work OK.
> Eugene
> 
> -----Original Message-----
> From: tcf-dev-bounces@xxxxxxxxxxx [mailto:tcf-dev-bounces@xxxxxxxxxxx] On Behalf Of Jeff Johnston
> Sent: Wednesday, May 30, 2012 1:43 PM
> To: tcf-dev@xxxxxxxxxxx
> Subject: Re: [tcf-dev] TCF repository doesn't seem to be working all of a sudden
> 
> I can't get /tcf/builds/juno/nightly to list with the p2 director either.  I had seen this once before in our
> Linux Tools repository where a line in either artifacts.xml or content.xml was in error (I can't
> remember which).
> 
> -- Jeff J.
> 
> On 05/30/2012 04:27 PM, Tarassov, Eugene wrote:
> > The build worked, and .../tcf/builds/juno/nightly is fine, but .../tcf/builds/juno/milestones still looks
> broken.
> > I'm sure what's wrong there.
> > Eugene
> >
> > -----Original Message-----
> > From: tcf-dev-bounces@xxxxxxxxxxx [mailto:tcf-dev-bounces@xxxxxxxxxxx]
> > On Behalf Of Tarassov, Eugene
> > Sent: Wednesday, May 30, 2012 11:37 AM
> > To: TCF Development
> > Subject: Re: [tcf-dev] TCF repository doesn't seem to be working all
> > of a sudden
> >
> > It must be side effect of
> > https://bugs.eclipse.org/bugs/show_bug.cgi?id=381001
> >
> > I fixed it, hopefully the repository will be back in about 20 min...
> >
> > Eugene
> >
> > -----Original Message-----
> > From: tcf-dev-bounces@xxxxxxxxxxx [mailto:tcf-dev-bounces@xxxxxxxxxxx]
> > On Behalf Of Jeff Johnston
> > Sent: Wednesday, May 30, 2012 11:23 AM
> > To: TCF Development
> > Subject: [tcf-dev] TCF repository doesn't seem to be working all of a
> > sudden
> >
> > The TCF milestones repository isn't working with our tycho builds all
> > of a sudden.  When I run the following command, I get an error.  Any ideas?
> >
> > bash $ eclipse -consolelog -nosplash -application
> > org.eclipse.equinox.p2.director -repository
> > http://download.eclipse.org/tcf/builds/juno/milestones -list
> > CompilerOracle: exclude
> > org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
> > CompilerOracle: exclude
> > org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<i
> > nit>
> > CompilerOracle: exclude
> > org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.in
> > stantiateTemplate
> > CompilerOracle: exclude
> > org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
> > CompilerOracle: exclude
> > org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isVa
> > lidSourceFile
> > CompilerOracle: exclude
> > org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidS
> > ourceFiles
> > !SESSION 2012-05-30 14:22:24.903
> > -----------------------------------------------
> > eclipse.buildId=M20110210-1200
> > java.version=1.6.0_22
> > java.vendor=Sun Microsystems Inc.
> > BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
> > Framework arguments:  -application org.eclipse.equinox.p2.director
> > -repository http://download.eclipse.org/tcf/builds/juno/milestones
> > -list Command-line arguments:  -os linux -ws gtk -arch x86_64
> > -consolelog -application org.eclipse.equinox.p2.director -repository
> > http://download.eclipse.org/tcf/builds/juno/milestones -list
> >
> > !ENTRY org.eclipse.equinox.p2.artifact.repository 4 1000 2012-05-30
> > 14:22:27.809
> > !MESSAGE No repository found at
> > http://download.eclipse.org/tcf/builds/juno/milestones.
> >
> > !ENTRY org.eclipse.equinox.p2.metadata.repository 4 1000 2012-05-30
> > 14:22:29.687
> > !MESSAGE No repository found at
> > http://download.eclipse.org/tcf/builds/juno/milestones.
> > Installation failed.
> > Unable to load repositories.
> > Application failed, log file location:
> > /home/jjohnstn/.eclipse/org.eclipse.platform_3.6.1_793567567/configura
> > tion/1338402144955.log
> >
> > !ENTRY org.eclipse.equinox.p2.core 4 0 2012-05-30 14:22:29.688
> > !MESSAGE Unable to load repositories.
> > _______________________________________________
> > tcf-dev mailing list
> > tcf-dev@xxxxxxxxxxx
> > http://dev.eclipse.org/mailman/listinfo/tcf-dev
> > _______________________________________________
> > tcf-dev mailing list
> > tcf-dev@xxxxxxxxxxx
> > http://dev.eclipse.org/mailman/listinfo/tcf-dev
> > _______________________________________________
> > tcf-dev mailing list
> > tcf-dev@xxxxxxxxxxx
> > http://dev.eclipse.org/mailman/listinfo/tcf-dev
> 
> _______________________________________________
> tcf-dev mailing list
> tcf-dev@xxxxxxxxxxx
> http://dev.eclipse.org/mailman/listinfo/tcf-dev
> _______________________________________________
> tcf-dev mailing list
> tcf-dev@xxxxxxxxxxx
> http://dev.eclipse.org/mailman/listinfo/tcf-dev
> _______________________________________________
> tcf-dev mailing list
> tcf-dev@xxxxxxxxxxx
> http://dev.eclipse.org/mailman/listinfo/tcf-dev
> _______________________________________________
> tcf-dev mailing list
> tcf-dev@xxxxxxxxxxx
> http://dev.eclipse.org/mailman/listinfo/tcf-dev