[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[smila-dev] JDK 1.6 Dependency

Hi Folks,

 

anyone who is trying to use SMILA should notice that there is not only a dependency on JDK 1.6 but also a dependency on the minor version of the JDK.

 

Please be sure to use a JDK larger or equal to jdk1.6.0_04 in that release a dependency update was made to the jdk. javax.xml.bind.annotation.XmlSeeAlso was added.

 

In other case you get exceptions like… if you start the crawlers…

 

Georg

 

Error loading DataSource with DataSourceId 'file': org.eclipse.smila.connectivity.framework.schema.exceptions.SchemaRuntimeException: com.sun.xml.internal.bind.v2.runtime.IllegalAnnotationsException: 4 counts of IllegalAnnotationExceptions

org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute is an interface, and JAXB can't handle interfaces.

                this problem is related to the following location:

                               at org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute

                               at protected java.util.List org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes._attribute

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes

                               at protected org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig._attributes

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig

The type of the getter is boolean but that of the setter is java.lang.Boolean. They have to be the same.

                this problem is related to the following location:

                               at public abstract boolean org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute.isAttachment()

                               at org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute

                               at protected java.util.List org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes._attribute

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes

                               at protected org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig._attributes

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig

                this problem is related to the following location:

                               at public abstract void org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute.setAttachment(java.lang.Boolean)

                               at org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute

                               at protected java.util.List org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes._attribute

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes

                                at protected org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig._attributes

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig

The type of the getter is boolean but that of the setter is java.lang.Boolean. They have to be the same.

                this problem is related to the following location:

                               at public abstract boolean org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute.isHashAttribute()

                               at org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute

                               at protected java.util.List org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes._attribute

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes

                               at protected org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig._attributes

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig

                this problem is related to the following location:

                               at public abstract void org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute.setHashAttribute(java.lang.Boolean)

                               at org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute

                               at protected java.util.List org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes._attribute

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes

                               at protected org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig._attributes

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig

The type of the getter is boolean but that of the setter is java.lang.Boolean. They have to be the same.

                this problem is related to the following location:

                               at public abstract boolean org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute.isKeyAttribute()

                               at org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute

                               at protected java.util.List org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes._attribute

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes

                               at protected org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig._attributes

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig

                this problem is related to the following location:

                               at public abstract void org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute.setKeyAttribute(java.lang.Boolean)

                               at org.eclipse.smila.connectivity.framework.schema.config.interfaces.IAttribute

                               at protected java.util.List org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes._attribute

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes

                               at protected org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig$Attributes org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig._attributes

                               at org.eclipse.smila.connectivity.framework.schema.config.DataSourceConnectionConfig