Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[riena-dev] RienaDialog / DialogView suggestions

Here are a couple of ideas and suggestions that would make RienaDialog
/ DialogView easier to use from my POV (with API changes):

1. RienaDialog should not be API. -- I suggest making it package
public. it only adds look-n-feel support
2. Rename RienaDialog (adds LnF support) to AbstractThemableDialog and
DialogView (adds View/Controller) to RienaDialog -- I can't think why
anybody would not want LnF support and V/C support. That means that
most people would extends DialogView. I thnk renaming it to
RienaDialog would be more intuitive.
3. Deprecate dialogView.build() in favor of dialogView.open() -- this
is the standard call to open a dialog in Eclipse
4. Rename DialogView.buildView() to DialogView.basicCreatePartControl
-  this is the method where we create the UI in regular views; more
similar naming
5. buildView() could be abstract, so that there is an obvious hint
that somebody extending DialogView needs to implement this method
(might cause problems with WindowBuilder though...)
6. Create OK and Cancel buttons by default -- currently everybody
extending DialogView has to create his own buttons and buttonRidgets.
This does not make sense to me. We should make the common case easy by
creating Ok, Cancel buttons and invoking addUIControl(...) for them.
This could happen in a protected method so it can be overwritten by
people needing other buttons
7. I could not find an easy way to set the dialog title. If there is
one please let me know -- ideally it should be something like
dialogView.setTitle(...) or maybe even a constructor parameter

Looking forward to your feedback.

Kind regards,
Elias.

-- 
Elias Volanakis | Technical Lead | EclipseSource Portland
elias@xxxxxxxxxxxxxxxxx | +1 503 929 5537 | http://eclipsesource.com


Back to the top