[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [rap-dev] Base rap runtime on 3.8 or 4.2?

On 11/14/2011 12:15 PM, Ralf Sternberg wrote:
> A) Switch to 4.2 as runtime base and ensure that our JFace/Workbench
> bundles remain compatible with 4.2 Equinox (not sure if there will be
> any incompatible changes in Equinox).
>
> B) Continue using 3.8 as runtime base and keep the runtime out of the
> Juno repository entirely.
>
> C) Continue using 3.8 as runtime base and keep only the basic target
> requirements bundle out of the Juno repository. We'd have to ensure
> that the RAP runtime works with Equinox 3.8 and 4.2.
>
> I'd prefer to look forward and go for A). Any thoughts?

Most RCP apps are still on 3.x and, I guess, not interested in moving to
4.x.

Wouldn't A) break the nice single-sourcing story for 3.x RCP apps?

Frank.