[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [rap-dev] Problem with M3 on osx

Hi Roberto,

Could you try to set "useCache" as indicated below to false (in readImageSize in class Image):

    try {
      ImageIO.setUseCache( false );
      BufferedImage image = ImageIO.read( input );
      ...

The cache is not needed as we read every image only once. And there seems to be a similar problem with tomcat deployment in some circumstances.

Thanks Jochen

 

-----Original Message-----
From: rap-dev-bounces@xxxxxxxxxxx [mailto:rap-dev-bounces@xxxxxxxxxxx] On Behalf Of Roberto Sánchez
Sent: Monday, May 07, 2007 9:34 AM
To: RAP project development-related communication
Subject: Re: [rap-dev] Problem with M3 on osx

I have the same problem, I don't think that is a javascript problem, I've created a new bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=185718

I was debugging the app and there is a problem with ImageIO.read(is) in method Image#readImageSize(InputStream inputStream), If I comment this method the application works fine.

Regards



2007/5/7, Frank Appel <fappel@xxxxxxxxxxxxxx>:

	Hi,
	
	thank you for your problem description but we are not sure about what could cause the problem. Seems as if the server is running, since the background image is delivered. Maybe there are some problems with the encoding of the javascript files. You may type 'javascript:' in the URL box of firefox to open the javascript console to see if there are any javascript problems reported. This may help us to get a glue what's happening. 
	
	Ciao
	Frank
	
	________________________________
	
	Von: rap-dev-bounces@xxxxxxxxxxx im Auftrag von Benedikt Arnold
	Gesendet: Do 03.05.2007 21:20
	An: rap-dev@xxxxxxxxxxx
	Betreff: [rap-dev] Problem with M3 on osx
	
	
	
	Hi,
	
	I'm new on this list and I'm currently working on an RAP application
	for my diploma thesis. I've got a windows workstation and an osx 
	powerbook both running Eclipse 3.3M6 with RAP 1.0M3.  I use Firefox
	as client on both machines. It is possible to run my application on
	the windows machine and I am able to access the app from firefox on
	osx and windows. 
	
	The problem is, that I can't run my application on my Powerbook. If I
	want to access the application I only got the screen with the blue
	gradient on top but not the workbench window.
	
	The problem appears first time I ran M3. The only difference is that 
	jetty runs on port 80 on windows and on port 8080 on mac os x.
	
	Greetings,
	Benedikt
	_______________________________________________
	rap-dev mailing list
	rap-dev@xxxxxxxxxxx 
	https://dev.eclipse.org/mailman/listinfo/rap-dev
	
	
	
	_______________________________________________
	rap-dev mailing list
	rap-dev@xxxxxxxxxxx <mailto:rap-dev@xxxxxxxxxxx> 
	https://dev.eclipse.org/mailman/listinfo/rap-dev
	
	
	




--
Roberto Sánchez Custodio
Director General

Tlf: 91 298 62 24
Fax: 91 187 71 37
Pº de la Habana 9-11
28036 Madrid
http://www.autonomind.com/