[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ptp-dev] Problem using the org.eclipse.ptp.remote.core.remoteServerOverride extension point

OK, I also answered in the bug, but Chris' answer seems better :)

Chris N is very good at finding bugs....   Thanks Chris.


...Beth

Beth Tibbitts
Eclipse Parallel Tools Platform  http://eclipse.org/ptp
IBM STG - High Performance Computing Tools
Mailing Address:  IBM Corp., 745 West New Circle Road, Lexington, KY 40511


Inactive hide details for Christopher Navarro ---04/04/2012 11:33:08 AM---It looks like inside the method checkForOverrides(...Christopher Navarro ---04/04/2012 11:33:08 AM---It looks like inside the method checkForOverrides(...) of  RemoteServerManager.class, the extension


    From:

Christopher Navarro <cmnavarr@xxxxxxxxxxxx>

    To:

Parallel Tools Platform general developers <ptp-dev@xxxxxxxxxxx>,

    Date:

04/04/2012 11:33 AM

    Subject:

Re: [ptp-dev] Problem using the org.eclipse.ptp.remote.core.remoteServerOverride extension point

    Sent by:

ptp-dev-bounces@xxxxxxxxxxx




It looks like inside the method checkForOverrides(...) of
RemoteServerManager.class, the extension remoteServerOverride is coming
up null so it never picks up overrides. I'll dig into it and see if I
can figure out why it doesn't find that extension element.

Regards,
Chris

On 04/04/2012 09:24 AM, Rodrigo Fraxino Araujo wrote:
> Hi,
> I'm sending this message to ptp-dev since I got no answer in ptp-user.
>
> I've been trying to use the org.eclipse.ptp.remote.core.remoteServerOverride extension point in
> order to override the default properties that are being set in org.eclipse.ptp.rdt.server.dstore.
>
> The problem is that even if I specify the same ID used by the plugin
> that is using the extension point (i.e.,
> org.eclipse.ptp.rdt.server.dstore.RemoteToolsDStoreServer), the
> properties (e.g., the java path of launchCommand) continue to be loaded
> from the first plugin that uses the extension point and not from mine.
>
> I think that this can be considered a bug and filed a bug report
>
https://bugs.eclipse.org/bugs/show_bug.cgi?id=375674
>
> Anyone knows if maybe I am doing something wrong?
>
> Thanks.
>
> Regards,
> Rodrigo.
>
> _______________________________________________
> ptp-dev mailing list
> ptp-dev@xxxxxxxxxxx
>
https://dev.eclipse.org/mailman/listinfo/ptp-dev
>

_______________________________________________
ptp-dev mailing list
ptp-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/ptp-dev



GIF image

GIF image