[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [platform-swt-dev] SwtBrowser crashing or hanging

Hi Grant,

I logged the bug at: https://bugs.eclipse.org/bugs/show_bug.cgi?id=365013

Thanks!

Yuhan

On Wed, Nov 23, 2011 at 6:55 AM, Grant Gayed <Grant_Gayed@xxxxxxxxxx> wrote:
Hi Yuhan,

Evaluating JS should not be a problem in general.  It's possible that you have either found a particular case that shows a problem, or are running with an unsupported configuration (eg.- older eclipse releases can have problems with newer linux distros as a result of changes in the native browser that gets embedded).  Please log a report with swt at https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform&component=SWT and be sure to specify your OS, eclipse version, and the dump file from the crash.

Grant




From:        Yuhan Zhang <yzhang@xxxxxxxxxxxxx>
To:        platform-swt-dev@xxxxxxxxxxx
Date:        11/22/2011 09:53 PM
Subject:        [platform-swt-dev] SwtBrowser crashing or hanging
Sent by:        platform-swt-dev-bounces@xxxxxxxxxxx




Hi All,

I have been playing with SwtBrowser for a few weeks. Mostly I'd like to open a url on a browser,
and run evaluate _javascript_ in it to collect data. However, while it appears that jre crashes quite often,
or at times it hangs, just with a simple Browser.setUrl(...) and Browser.evaluate( jsString ).

The browser is much stabler when I used it to take screenshot without touch the _javascript_ part.

Is this a known issue with evaluating _javascript_ in a SwtBrowser? any tip at avoiding jre crashing when
evaluating _javascript_?

Any feed back will be appreciated.

Thank you.


Yuhan
_______________________________________________
platform-swt-dev mailing list
platform-swt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/platform-swt-dev


_______________________________________________
platform-swt-dev mailing list
platform-swt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/platform-swt-dev