[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [platform-help-dev] cross plug-in referencing - why no "root"

Brian, it turns out that what you want won't work in the infocenter
scenario, for the first reason mentioned below.
In the workbench help, things are under our control, but for infocenters
the launching url could be different, and the absolute path won't be
resolved correctly.

-Dorian



|---------+----------------------------------->
|         |           Brian                   |
|         |           Gillan/Raleigh/IBM@IBMUS|
|         |           Sent by:                |
|         |           platform-help-dev-admin@|
|         |           eclipse.org             |
|         |                                   |
|         |                                   |
|         |           11/20/2002 01:40 PM     |
|         |           Please respond to       |
|         |           platform-help-dev       |
|         |                                   |
|---------+----------------------------------->
  >-------------------------------------------------------------------------------------------------------------|
  |                                                                                                             |
  |       To:       platform-help-dev@xxxxxxxxxxx                                                               |
  |       cc:                                                                                                   |
  |       Subject:  Re: [platform-help-dev] cross plug-in referencing - why no "root"                           |
  |                                                                                                             |
  |                                                                                                             |
  >-------------------------------------------------------------------------------------------------------------|







>The link is interpreted by the browser, so the absolute path will be
>translated as http://your_server/org.eclipse.help/livehelp.js which won't
>work.
>We could investigate some possible implementations of the default webapp
>(ROOT) so it would redirect to the help webapp, as long as this is
possible
>and the app server plugin is under the help system's control.

>-Dorian


Do I need to put in a formal request for this? I would think this would be
something a lot of folks would want to do, not only for the case of the
javascript reference, but also for doing linking between help topics in
different plugins and not have to worry about where you are relative to
your plugin directory structure.

Brian

Phone: (919) 254-1765 Tie-line: 8-444-1765
GILLAN AT RALVM13 / bgillan@xxxxxxxxxx
Information Technology and Strategy
Dept. E14D Bld. 500
RTP, NC

_______________________________________________
platform-help-dev mailing list
platform-help-dev@xxxxxxxxxxx
http://dev.eclipse.org/mailman/listinfo/platform-help-dev