[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [photran] Debugger "can't find a source file"

ok thanks a lot for all your answers: that was indeed the problem. By disabling "stop on startup at main", the debugger now works fine.
Sincerely,
Bruno

Kurt Hendle wrote:
This seems to be a problem in Windows specifically. This bug is in Bugzilla at https://bugs.eclipse.org/bugs/show_bug.cgi?id=280492

Disabling "Stop on startup at main" actually gets rid of the error at the beginning of the program, but if you step through the program all the way to the end (assuming you had a breakpoint set and hit it) you will get this error again, only it appears to be completely harmless since it comes up after the "end program" statement.

Kurt


On Mon, Jul 27, 2009 at 1:33 PM, Greg Watson <g.watson@xxxxxxxxxxxx> wrote:
I'd say it's the Fortran startup code that is supplied as part of the compiler. Try disabling "Stop on startup at main" (debugger tab in launch configuration) and manually setting a breakpoint in your Fortran code.

Greg


On Jul 27, 2009, at 2:25 PM, Bruno wrote:

Thanks for your help Jim, but this does not work in my case, most probably because I use MinGW rather than Cygwin. I assume that I have to do something equivalent using MinGW, but I don't know what.

Also, I don't know what "../../../gcc-trunk/libgfortran/fmain.c" is... I don't have such directories and file in my MinGW installation.

Bruno

Jim Carpenter wrote:
See the section on "Debugging C/C++ Projects" in the CDT FAQ:

http://wiki.eclipse.org/CDT/User/FAQ

Jim


Jim Carpenter wrote:
You may need to add a path mapping so that the debugger can find sources:

Window -> Preferences -> C/C++ -> Debug-> Common Source Lookup Path -> Add

You may need to map /cygdrive/c to C:\ on the local file system.

Jim


Bruno wrote:
Hello,

I use Eclipse SDK 3.4 + CDT 5.0.2 + MinGW/MSYS with gfortran, on Windows XP. I have no problem compiling and running my Fortran project (Executable GNU Fortran, GCC Toolchain), but I can't debug it... In the Debug Configuration, I select the "gdb Debugger", but I always get the message:

Can't find a source file at "../../../gcc-trunk/libgfortran/fmain.c"
Locate the file or edit the source lookup path to include its location.

As I stated, I use MinGW, and I installed gdb for MinGW (mingw-gdb) available here: http://www.mingw.org/wiki/Getting_Started

Does anyone have an idea?

Thanks

Bruno
_______________________________________________
photran mailing list
photran@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/photran



_______________________________________________
photran mailing list
photran@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/photran


_______________________________________________
photran mailing list
photran@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/photran

_______________________________________________
photran mailing list
photran@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/photran


_______________________________________________ photran mailing list photran@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/photran