[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[pdt-dev] Target platform questions

Hi Team,

I have two problems for today, both related to target platform.

1. Currently we checking our builds with luna and mars repo. I have proposition to start build with mars (base) and neon (next).  Are you agree?

2. Independently from base repository, we currently trying to keep api compatibility with eclipse 3.8. Because I would like to start using Mars api (IAdapter generics, parallel jobs, e4) I have a proposition to introduce update api base line policy: Update api base line after each "*.1"  release. What you think?

3. Last problem is BREE version, now set to 1.6. Mars targets it to 1.7 (EOL). I would like to update also in PDT and introduce policy to keep min. java in sync with platform. Again, what you think?

Dawid PakuÅa
+48 795 996 064