[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [pde-build-dev] PDE silent death


If you are getting a return code of 13, there is probably something more fundamental than PDE-Build that is going wrong.

13 is the return code that tells the eclipse launcher to display an error dialog.  You could try using the eclipse launcher to run that
build and see what the error message is.  Depending on the error, it may just be something like "An error has occured, check the log file".

There may be a log file in the eclipse/configuration directory.

-Andrew


"Graham Leggett" <minfrin@xxxxxxxx>
Sent by: pde-build-dev-bounces@xxxxxxxxxxx

12/21/2007 05:43 AM

Please respond to
"Eclipse PDE Build developers list." <pde-build-dev@xxxxxxxxxxx>

To
pde-build-dev@xxxxxxxxxxx
cc
Subject
[pde-build-dev] PDE silent death





Hi all,

I have just updated the headless build of my Eclipse plugin to use Eclipse
v3.3, and on my Windows machine it works fine.

Trying to do the exact same headless build on our Linux machine, any
attempt to trigger the headless build results in the build exiting
silently with the dreaded error 13 - no error message is logged, no clue
is given as to what might be wrong.

The ant docs mention the -verbose flag to coax ant into telling the world
what it is doing, but the PDE ant runner seems to strip off this option,
and so ant stays silent as a tomb.

Can anyone recommend a way to convince the PDE build to break its silence
and give me a clue as to what might be wrong?

The build looks like this:

[INFO] [pde:clean {execution: clean-pde}]
[INFO] Startup jar found at:
/udd001/app/alchemy/java/Eclipse/eclipse-jee-europa-fall2-win32/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar
[INFO] java -classpath
/udd001/app/alchemy/java/Eclipse/eclipse-jee-europa-fall2-win32/eclipse/plugins/org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar
org.eclipse.equinox.launcher.Main -application
org.eclipse.ant.core.antRunner -buildfile
/udd001/app/alchemy/development/trader/trunk/alchemy-eclipse-rcp/plugins/com.standardbank.alchemy.plugin/build.xml
clean
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error returned by PDE build. The cause for this error should be
found within the PDE build logfile.
[INFO]
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]
------------------------------------------------------------------------

(there is no build logfile).

Regards,
Graham
--


_______________________________________________
pde-build-dev mailing list
pde-build-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/pde-build-dev