[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Java 1.5 adoption

Hey,

while trying to remove compilation warning, I found that bundle BREE
doesn't match the effective tycho one.

I've reported https://bugs.eclipse.org/bugs/show_bug.cgi?id=421339 with
patch https://git.eclipse.org/r/#/c/18227/, that:
* removes jsr14 targets from bundles
* sets a majority of BREEs to 1.5 (was 1.5, 1.4 and Foundation 1.x, but
Tycho was choosing the lowest one).

As this is potentially dangerous operation, I'd like all to be aware.

Please comment if you think it will break something.
-- 
Krzysztof Daniel <kdaniel@xxxxxxxxxx>
Red Hat