[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Creating InstallableUnits on the fly

On Tue, 2013-07-02 at 13:28 +0200, Krzysztof Daniel wrote:
> Ok, solved by 
> dropletIU.setCapabilities(new IProvidedCapability[]
> {MetadataFactory.createProvidedCapability(IInstallableUnit.NAMESPACE_IU_ID, dropletIU.getId(), dropletIU.getVersion())});
> 
> 
Unfortunately this was not a valid solution.

I get plenty of those:
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2013-07-02 15:17:46.084
!MESSAGE Unable to satisfy dependency from a 1.0.0 to
file:/tmp/droplets/ab_up/ [1.0.0].

-- 
Krzysztof Daniel <kdaniel@xxxxxxxxxx>
Red Hat