[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] [tycho-user] Trouble upgrading Mac Bundles

This is a publisher / metadata gen issue. Maybe the invocation from tycho is incorrect.



On 2013-05-09, at 10:56 AM, Doug Schaefer <dschaefer@xxxxxxx> wrote:

And I can confirm that manually adding the missing IU, "tooling*.executable.macosx.x86-bundled", into the repository's content.xml works.

Is this the p2 director not inserting this correctly, or is it tycho not passing in the right parameters to the director, or am I missing an argument in my pom?

Thanks,
Doug.

From: Doug Schaefer <dschaefer@xxxxxxx>
Date: Thursday, 9 May, 2013 9:27 AM
To: Tycho user list <tycho-user@xxxxxxxxxxx>, "p2-dev@xxxxxxxxxxx" <p2-dev@xxxxxxxxxxx>
Subject: Re: [tycho-user] Trouble upgrading Mac Bundles

To further my investigation, I see a macosx-bundled filter in the p2content.xml file. It doesn't seem to be set true when the repository is created taking the non-bundle executable IU. Is there a way to turn this filter on when generating the repository?

From: Doug Schaefer <dschaefer@xxxxxxx>
Reply-To: Tycho user list <tycho-user@xxxxxxxxxxx>
Date: Thursday, 9 May, 2013 1:00 AM
To: Tycho user list <tycho-user@xxxxxxxxxxx>
Subject: Re: [tycho-user] Trouble upgrading Mac Bundles

Sorry, I meant can't upgrade. But I guess that's obvious from the error messageâ

From: Doug Schaefer <dschaefer@xxxxxxx>
Reply-To: Tycho user list <tycho-user@xxxxxxxxxxx>
Date: Thursday, 9 May, 2013 12:57 AM
To: "tycho-user@xxxxxxxxxxx" <tycho-user@xxxxxxxxxxx>
Subject: [tycho-user] Trouble upgrading Mac Bundles

Hey gang,

I'm using the new platform specific rootFolders feature in 0.18-SNAPSHOT tycho to generate the Mac version of my product as a Mac app bundle. I'm pretty sure this worked at one point but now I can upgrade from build to build. I get the following:

Cannot complete the install because one or more required items could not be found.
  Software being installed: QNX Momentics IDE 10.2.0.v201305090421 (com.qnx.tools.bbt.ide.ide-internal 10.2.0.v201305090421)
  Missing requirement for filter properties ~= $0: toolingcom.qnx.tools.bbt.ide.ide-internal.application 10.2.0.v201305090421 requires 'toolingcom.qnx.tools.bbt.ide.ide-internal.executable.cocoa.macosx.x86-bundled [10.2.0.v201305090421]' but it could not be found
  Cannot satisfy dependency:
    From: QNX Momentics IDE 10.2.0.v201305090421 (com.qnx.tools.bbt.ide.ide-internal 10.2.0.v201305090421)
    To: toolingcom.qnx.tools.bbt.ide.ide-internal.application [10.2.0.v201305090421]

I see the tooling*-bundled IU in the p2content.xml file but not in the content.jar in the repository. Is this a bug, or am I doing it wrong? Or is this something wrong in p2?

Thanks!
Doug.
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev