[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Windows 7 UAC and the p2 director

Hello all, 

I'm currently working on an RCP application that is required to run on Windows 7 and be installed into the dreadful place of C:\Program Files\ .

I'm also using the p2 director to pre-install an IU at build time on my build machine.  This gives the application the ability to update just that feature, and not the other feature that makes up the core of my RCP application.

More context on what I'm doing is here... http://dev.eclipse.org/mhonarc/lists/p2-dev/msg04735.html

This was all working fine on our development machines which have Windows UAC turned down to it's lowest level, "Never Notify".  But, when we started testing on machines that had the Windows UAC set to it's default level, the RCP application hides the update sites that I had placed into the application via p2 touchpoints, and disabled the ability to update the features that I'd like to have updated automatically.

I've read many bugzilla pages about these issues from as far back as 2008.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=249133'
https://bugs.eclipse.org/bugs/show_bug.cgi?id=322929
https://bugs.eclipse.org/bugs/show_bug.cgi?id=343768

To work around this problem, I've turned to the p2 director application again...


This time I'm trying to run the p2 director to install the features I need on the client machine using this command line...  

C:\Program Files\MyCoreRCPApp\eclipsec.exe -application org.eclipse.equinox.p2.director -repository http://my.domain.com/myapp/ -installIU com.mydomain.myapp.feature.group -destination "C:\Program Files\MyCoreRCPApp" -profile DefaultProfile -shared

This fails and complains of missing dependencies... 


Installing com.mydomain.myapp.feature.feature.group 1.1.18.20120802-2124.
Installation failed.
Cannot complete the install because one or more required items could not be found.
 Software being installed: My Application Feature 1.1.18.20120802-2124 (com.mydomain.myapp.feature.feature.group 1.1.18.20120802-2124)
 Missing requirement: Apache Geronimo Activation Plug-in 1.1.0.v201108011116 (javax.activation 1.1.0.v201108011116) requires 'package ja
vax.imageio 0.0.0' but it could not be found
 Cannot satisfy dependency:
  From: My Application Feature 1.1.18.20120802-2124 (com.mydomain.myapp.feature.feature.group 1.1.18.20120802-2124)
  To: com.mydomain.myapp.ui.feature.feature.group [1.0.17.20120730-1946]
 Cannot satisfy dependency:
  From: My Application UI Feature 1.0.17.20120730-1946 (com.mydomain.myapp.ui.feature.feature.group 1.0.17.20120730-1946)
  To: com.mydomain.myapp.ws.client [1.1.6,1.2.0)
 Cannot satisfy dependency:
  From: My Application WS Client 1.1.15.20120730-1455 (com.mydomain.myapp.ws.client 1.1.15.20120730-1455)
  To: bundle javax.xml.rpc 1.1.0
 Cannot satisfy dependency:
  From: JAX-RPC 1.1.0.v201005080400 (javax.xml.rpc 1.1.0.v201005080400)
  To: package javax.xml.soap 0.0.0
 Cannot satisfy dependency:
  From: SAAJ 1.3.0.v201105210645 (javax.xml.soap 1.3.0.v201105210645)
  To: package javax.activation 0.0.0
Application failed, log file location: C:\Users\twindham\.eclipse\org.eclipse.platform_3.7.0_219624832\configuration\1344441592283.log



I've confirmed that I can successfully install this feature using my Core RCP application with the dialog found at Help > Install New Software ... this lets me enter the exact same url that I used for the -repository parameter when calling the p2 director.  

So, I wonder if I'm doing something wrong when using the p2 director application that is causing it to fail like this.

Any help is greatly appreciated.


Thanks,
--
Trace Windham